1

I recently made a Mint live USB stick with persistent storage using Linux Live USB Creator. When I try to boot from the USB stick, it fine if I select the Grub option "Live mode" but fails if I select "Persistence mode".

The output it gives looks like this:

Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ...

BusyBox v1.22.1 (Ubuntu 1:1.22.0-15ubuntu1) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) [    31.968566] ACPI Warning: \_SB.PCIO-PEGO-VID-_DSM:Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160422/nsarguments-95)
[    31.986683] ACPI: \_SB_.PCIO.PEGO.VID_: failed to evaluate _DSM
(initramfs) [    31.968566] ACPI Warning: \_SB.PCIO-PEGO-VID-_DSM:Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160422/nsarguments-95)

followed by suspending console etc.

Some additional information:
The USB stick has two partitions:
Partition 1: 16.9 Gb, FAT32, Mint is installed on this partition.
Partition 2: 12Gb, ext4, labelled "casper-rw", supposed to be the persistent storage.

According to the tutorials found online on creating a Live USB Stick with more than 4Gb of persistent storage, I deleted the casper-rw file which was created by LiLi USB Creator on partition 1.

Does anyone know what causes this problem and how to fix it?

[EDIT] It boots fine with persistence if I use the casper-rw loopback file which, sadly, limits the persistent storage to 4gb.

0

After a lot of digging, I found the information that this problem exists since version 17.3 (I think it said this was because of an underlying ubuntu update but I'm not quite shure). Therefore I tried the same process with Linux Mint 17.2 and it worked without any problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.