2

My hostapd works very well on my raspberry Pi3. But if I put root filesystem in readonly, it does not work. I have put some folders like /var/run and /tmp in a ramdisk filesystem.

I have seen something in log files when the root filesystem is readonly:

random: Cannot read from /dev/random: Resource temporarily unavailable
random: Got 0/20 bytes from /dev/random
random: Only 0/20 bytes of strong random data available from /dev/random
random: Not enough entropy pool available for secure operations

So I think something is wrong with /dev/random when the root filesystem is in readonly mode.

What should I do to fix that ?

-- Edit -- Here is the output of ls -l /dev/random:

crw-rw-rw- 1 root root 1, 8 nov.  12 16:17 /dev/random
  • Can you add the output of ls -l /dev/random (to your question, not as a response comment)? – Andy Dalton Nov 10 '17 at 21:37
  • Do you have the hardware random number generator enabled? If no, you might take a look at: nico-maas.de/?p=1562 You'll want to install and configure package rng-tools. – Andy Dalton Nov 13 '17 at 16:01
  • It is a raspberry pi3 so i do not know if there is an hardware random number genrator... – Bob5421 Nov 14 '17 at 18:20
  • Raspberry pi 3 has a RNG. – Andy Dalton Nov 14 '17 at 21:18
  • Okay so what should i do to make it work ? – Bob5421 Nov 15 '17 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.