1

So I ran apt-get dist-upgrade, and now my system do not start. I get past the boot menu. Then I see file system check stuff. Something like:

/dev/sda1: clean 34534/324344 files, 23445435/234435466 blocks

(Numbers are made up. Did not think the actual numbers were relevant)

This blinks on the screen for a couple of minutes until it stabalizes. I cannot do anything. I've tried pressing Ctrl+Alt+FX 1-12 but no response. Ctrl+Alt+Delete reboots.

It responds to ping and I can login via ssh.

I suspect it has something to do with the graphics drivers, since I have had problems with them in the past. It is a Nvidia card.

In /var/log/kern.log I have this at the end:

Nov 10 13:41:56 klutt kernel: [  324.275907] nvidia-modeset: Freed GPU:0 (GPU-f5522274-0ae3-8a19-a228-47e2a3b8ac28) @ PCI:0000:01:00.0
Nov 10 13:41:57 klutt kernel: [  325.164463] nvidia-modeset: Allocated GPU:0 (GPU-f5522274-0ae3-8a19-a228-47e2a3b8ac28) @ PCI:0000:01:00.0
Nov 10 13:41:57 klutt kernel: [  325.521060] nvidia-modeset: Freed GPU:0 (GPU-f5522274-0ae3-8a19-a228-47e2a3b8ac28) @ PCI:0000:01:00.0
Nov 10 13:41:58 klutt kernel: [  326.436102] nvidia-modeset: Allocated GPU:0 (GPU-f5522274-0ae3-8a19-a228-47e2a3b8ac28) @ PCI:0000:01:00.0
Nov 10 13:41:59 klutt kernel: [  326.781826] nvidia-modeset: Freed GPU:0 (GPU-f5522274-0ae3-8a19-a228-47e2a3b8ac28) @ PCI:0000:01:00.0
Nov 10 13:42:00 klutt kernel: [  327.679554] nvidia-modeset: Allocated GPU:0 (GPU-f5522274-0ae3-8a19-a228-47e2a3b8ac28) @ PCI:0000:01:00.0
Nov 10 13:42:00 klutt kernel: [  328.044412] nvidia-modeset: Freed GPU:0 (GPU-f5522274-0ae3-8a19-a228-47e2a3b8ac28) @ PCI:0000:01:00.0
Nov 10 13:42:01 klutt kernel: [  328.891106] nvidia-modeset: Allocated GPU:0 (GPU-f5522274-0ae3-8a19-a228-47e2a3b8ac28) @ PCI:0000:01:00.0
Nov 10 13:42:01 klutt kernel: [  329.238838] nvidia-modeset: Freed GPU:0 (GPU-f5522274-0ae3-8a19-a228-47e2a3b8ac28) @ PCI:0000:01:00.0

but it goes on for 60 rows or so.

I tried adding GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" to /etc/default/grub. This made the screen stop flickering, but I still do not get to Gnome login. I can still ssh.

1

I logged in via ssh and ran apt install nvidia-drivers and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.