0

I have been trying to follow this guide: https://www.howtoforge.com/tutorial/how-to-encrypt-directories-and-partitions-with-ecryptfs-on-debian/ to encrypt the home directory on my pi with out a password by saving the password on a file onto a usb. But the issue is that the pi boots up to a login screen and prompts for a password. The only difference to the configuration in the guide I have made is that my usb is ntfs and the name of the directory that is being encrypted (pi) and the password. I tried it again and afterwards when the pi booted up it said root account was locked and I only had command line access to the system.

Are there any passwordless encryption alternatives that I can use? As the pi will have a display but no keyboard.

  • This might be a use case for writing custom firmware. – Ignacio Vazquez-Abrams Nov 10 '17 at 3:40
  • To be honest I don't think I am capable of doing that, but could you expand on that idea? – somerandomguy95 Nov 10 '17 at 3:48
  • Perhaps the use of ntfs, which is a fuse filesystem, is finished asynchronously and so not ready when the ecrypfs starts. Are you using mount -a in /etc/rc.local? Perhaps do it with 2 explicit mount commands (mount /dev/sdb1;sleep 2;mount /home/pi). Doesnt raspian auto mount entries in fstab? If so add option noauto to the 2 fstab entries. – meuh Nov 10 '17 at 19:32
  • Yes I was using mount -a, just tried the two separate mounts and it made no difference. Also added the noauto for the two entries. – somerandomguy95 Nov 10 '17 at 21:03
0

What are firmware name and version that you was deployed on your Raspberry?

Some keyboards are not be supported by Raspberry firmware. (caused by driver or power supply is not enough)

and

Some firmware version don't support generic keyboard.

==> Confirm the encoded password and input from keyboard are right! I've used armbian for my lab and it's running stably.

  • I'm using raspbian Jessie x86. But I realized why you are commenting about the keyboard. I meant that the device will only have a display, as in no keyboard or mouse will be attached to the device. – somerandomguy95 Nov 10 '17 at 3:11
  • To be honest I have not tried it, I didn't think it would be an issue but I can try to reformat another USB to vfat and try it tomorrow. – somerandomguy95 Nov 10 '17 at 3:44
  • Did you tried with vfat successfully? Let show the content of /etc/fstab with the line mount ntfs usb. – Tech. Pro Nov 10 '17 at 3:44
  • Here is the /etc/fstab content (sorry about the formatting - it won't let me add extra lines): /dev/sdb1 /mnt/usb ntfs ro 0 0 /home/pi /home/pi ecryptfs defaults 0 0 – somerandomguy95 Nov 10 '17 at 3:45
  • Try ntfs-3g: /dev/sdb1 /mnt/usb ntfs-3g permissions 0 0 (Note that: vfat do not have its own permission policy --> ro option is not real readonly.) – Tech. Pro Nov 10 '17 at 4:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.