5

I have a BenQ gw2765 monitor with 2560x1440 resolution... but my computer will only give it a maximum of 1920x1080 resolution.

The monitor is connected to my Lenovo Thinkpad X1 laptop via an HDMI-MiniDP connector. The laptop is running a brand-new installation of KDE's Neon (based on Ubuntu): KDE neon 5.11, KDE Plasma Version 5.11.2, KDE Fameworks Version 5.29.0, Qt Version 5.9.1.

A few years ago I tried in vain to get this working with some xrandr stuff. I was hoping that with this new installation would just work.

When I dig around the internet I'm surprised how little I see about this; I saw recommendations to "just use Gnome3 cuz it works" on one end of the spectrum and on the other end of the spectrum were questions by people who actually know what xrandr is.

I don't know what the x-server is or how it works, but if I need to edit some xorg.conf file or something I'm ready to try. I'd just love a little guidance, or a point-in-the-right-direction, in case your wisdom might help me avoid breaking things :)


edit:

$ sudo lshw -c video
   description: VGA compatible controller
   product: 3rd Gen Core processor Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 09
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:28 memory:f0000000-f03fffff memory:e0000000-efffffff ioport:4000(size=64) memory:c0000-dffff

Also:

When I sudo apt-get install xserver-xorg-video-all it wants to remove a package named "neon-desktop" which sounds dangerous as I'm using https://neon.kde.org/. ((and I'm ulta-cautious of removing packages right now because last week apt-get install ruby-dev uninstalled so much stuff that it resulted in kernel panic everytime I tried to boot {hence the brand-new os now}))


I found https://forum.kde.org/viewtopic.php?f=309&t=141545#p380311 which sounds quite identical to the issue I'm facing, but that solution is not working for me

$ cvt 2560 1440 60
  cvt# 2560x1440 59.96 Hz (CVT 3.69M9) hsync: 89.52 kHz; pclk: 312.25 MHz
  Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
$ sudo xrandr --newmode "2560x1440_60.00" 312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
$ sudo xrander --admode HDMI-1 2560x1440_60.00

This appears like it would work: it adds a display setting that's listed by xrandr and then the new size is available in KDE's system settings... but when I select it in the system settings gui and click 'apply' it resets back to the previously selected setting. I've tried toggling back and forth between different sizes but won't display at the proper large size.

The current xrandr with the 2560x1440_60.00 at the bottom:

Screen 0: minimum 320 x 200, current 1920 x 1980, maximum 8192 x 8192
LVDS-1 connected primary 1600x900+160+1080 (normal left inverted right x axis y axis) 309mm x 174mm
   1600x900      59.97*+
   1440x900      59.89  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   800x512       60.17  
   700x525       59.98  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
VGA-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   1920x1080     60.00*   50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   832x624       74.55  
   800x600       75.00    60.32  
   720x576       50.00  
   720x576i      50.00  
   720x480       60.00    59.94  
   720x480i      60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
   2560x1440_60.00  59.96  
DP-1 disconnected (normal left inverted right x axis y axis)

And then when I reboot the computer the 2560x1440_60.00 is no longer listed by xrandr.

  • 2
    Install the right drivers for you video card; resolutions are independent from Desktop Environment. For example: apt install xserver-xorg-video-all – Ipor Sircer Nov 9 '17 at 18:07
  • Oh that sounds much better than other xrandr/etc options I had seen. How do I know what the right drivers are? Should I just start with the xserver-xorg-video-all? – alec Nov 9 '17 at 18:18
  • Now that you have something that works you should be able to put a file in /etc/xorg.conf.d with it. – Ignacio Vazquez-Abrams Nov 10 '17 at 2:12
  • @IgnacioVazquez-Abrams thanks for following up... but I don't actually have it working. When I select the 2560x1440 size in the gui it resets back to the smaller size and cannot be set/saved at the large size. Do you mean that adding something to /etc/xorg.conf.d will solve that? – alec Nov 10 '17 at 2:33
  • No, adding that modeline to the configuration won't force it to work. – Ignacio Vazquez-Abrams Nov 10 '17 at 2:34
1

This isn't an answer, strictly speaking, but I didn't want it to get buried in the existing comment section:

This appears like it would work: it adds a display setting that's listed by xrandr and then the new size is available in KDE's system settings... but when I select it in the system settings gui and click 'apply' it resets back to the previously selected setting.

I experienced this exact problem and struggled to find other reports of this issue online. I double-checked my GPU's spec sheet, which claimed that its 4K display support was just a few pixels shy of my actual display resolution (3280x2160 display vs. 3280x2000 supported by GPU). This spec conflicted with the computer manufacturer's spec sheet, which claimed support for resolutions up to 4096x2160.

In a last-ditch effort, I replaced my HDMI cable with a DisplayPort cable and now it works up to 3280x2160@30Hz. Oddly, the HDMI cable was not the problem—I had used the very same cable to connect the monitor to my laptop with no problems whatsoever.

If anyone else experiences this problem, I would encourage you to:

  1. Find the spec sheet for your GPU online. In my case, I followed the instructions on this official Intel support page, which led me to the first spec sheet linked above.

  2. If all else fails, try connecting via DisplayPort rather than HDMI (or vice versa).

  • In the question, OP said the connection was originally a HDMI-MiniDP adapter. Such an adapter needs to include a level shifter chip, and the bandwidth that chip is capable of may restrict the maximum resolution achievable. DisplayPort and MiniDP are equivalent, just a different physical connector. Wikipedia has good information: en.wikipedia.org/wiki/DisplayPort#DisplayPort_dual-mode_(DP++) – telcoM Oct 9 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.