2

I have upgraded my office server to Ubuntu server 16.04, but I have a problem with virtual terminals: they don't open.

The system boot correctly, also ssh works, but if I want to use the console by the server's keyboard, it's not possible because it does not show me the login prompt.

On the principal screen I see a list of green OK, and if I change to other terminals (ctrl+alt+F2 and so) I see a black screen.

I've tried to enable getty with this command

systemctl enable getty@.service

but it doesn't work. If I try to force the start of getty on tty1 (for example) with the command

systemctl start getty@tty1

nothing happened and no errors are displayed.

The only way to start a virtual terminal is with this command

service getty@tty1 start

I must use ssh to control the server. I also edited the /etc/systemd/logind.conf file, but nothing is changed.

This is the logind.conf file content

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as
published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See logind.conf(5) for details.

[Login]
NAutoVTs=6
ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#UserTasksMax=12288

How can I get console tty's to show a login prompt on their own?

-1

I had a Ubuntu 16.04 Server fail to load TTY7, but TTY1-6 worked. If systemctl start works, you can use enable.

sudo systemctl enable getty@tty1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.