1

I am using Ubuntu 16.04 64 bit to try to capture RGB and Depth images from a Realsense SR300 depth camera.

I have installed the appropriate SDK etc, and the camera is being recognised and producing RGB data. There is also a separate stream producing depth data, but I cannot view this.

When I use the tools that accompany the SR300, namely realsense-viewer, I am greeted with an error:

RealSense error calling rs2_pipeline_start_with_config(pipe:0xb29f40, config:0xb284e0):
Requested pixel format is not natively supported by the Linux kernel and likely requires a patch for fourcc code INZI!
Alternatively please upgrade to kernel 4.12 or later. Last Error: Inappropriate ioctl for device

My kernel version is 4.12.14-041214-generic.

Googling this problem leads me to this thread. Apparently the last post is a patch script that will fix the issue, but I have no idea what to do with it.

Any guidance I could get on resolving this issue would be appreciated

3
  • Funny, I had exactly the same error but with 4.10 kernel. I have updated to 4.12.14-041214 and now I am able to execute realsense-viewer with SR300 camera. Firmware version of the camera: 3.21.0.0
    – ikaro
    Nov 9 '17 at 15:22
  • Thanks for letting me know, I've tried 4 different kernels now, and still no luck. My camera firmware version is 3.15.0.0 so maybe that's the problem
    – James
    Nov 9 '17 at 15:54
  • You can try this tool for windows that upgrade firmware easily when it starts
    – ikaro
    Nov 10 '17 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.