0

I recently tried to dist-upgrade my Debian testing system but I've got error:

hubot@debian:~$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 firefox-esr : Depends: libgtk-3-0 (>= 3.0.0) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

The result of command sudo apt-cache policy firefox-esr:

firefox-esr:
  Installed: 52.4.0esr-2
  Candidate: 52.4.0esr-2
  Version table:
 *** 52.4.0esr-2 500
        500 http://ftp.cz.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
     52.4.0esr-1~deb9u1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages

After removing firefox-esr, updating and upgrading:

$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk-3-0 : Depends: libwayland-egl1-mesa (>= 10.0.2) but it is not going to be installed or
                       libwayland-egl1
              Recommends: libgtk-3-bin
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
$ sudo apt purge --remove libgtk-3-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xul-ext-mozvoikko : Depends: iceweasel (>= 4.0) but it is not going to be installed or
                              firefox (>= 4.0) but it is not installable or
                              firefox-esr (>= 4.0) but it is not going to be installed or
                              thunderbird (>= 5.0) but it is not going to be installed or
                              icedove (>= 5.0)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
  • 1
    remove firefox-esr , then update , upgrade and reinstall it – GAD3R Nov 8 '17 at 7:33
  • 1
    Please provide output of apt-cache policy firefox-esr. Please paste command and output in your question, not as a comment, please. – Faheem Mitha Nov 8 '17 at 8:09
  • 3
    I'm gonna be harsh with you here: It's called the testing branch for a reason. It's where Debian puts packages that are almost ready for production so they can hammer the last remaining bugs out. If you can't deal with the occasional dependency breakage you should not be using it in the first place. – Shadur Nov 8 '17 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.