0

I'm trying to create the following setup: I want to communicate to an internet phone adapter (a Linksys PAP2) from my computer. I can communicate with it fine when it's connected with LAN cable to the local network. However I now want to connect it directly to my computer using a LAN-USB adapter (this one or very similar).

Note that I'm not trying to get internet through the USB adapter or to supply internet to the phone adapter through the USB adapter, I just want to communicate with the phone adapter through the USB adapter. I want to keep access to the internet on my computer as it is.

When I make the connection (phone adapter - LAN cable - USB adapter - computer) The device shows up in ip link:

7: enp0s16f1u1: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:e0:4c:53:44:58 brd ff:ff:ff:ff:ff:ff

I can then do this:

ip link set enp0s16f1u1 up
ip addr add 192.168.99.1 dev enp0s16f1u1
ping 192.168.99.1

Which is successful, although I'm not sure whether the USB adapter is responding or (hopefully) the phone adapter behind it. Also I can't reach the adapter's configuration website at the IP, which was possible on the local network. I thought perhaps dhcpcd enp0s16f1u1 could help, but this results in the following:

DUID 00:01:00:01:1c:44:4e:84:ac:9e:17:84:60:cf
enp0s16f1u1: IAID 4c:53:44:58
enp0s16f1u1: adding address fe80::31c0:b3d7:4414:b3b8
enp0s16f1u1: soliciting a DHCP lease
enp0s16f1u1: soliciting an IPv6 router
enp0s16f1u1: no IPv6 Routers available
timed out
dhcpcd exited

Via a telephone connected to the phone adapter, I can configure some options that might be helpful:

  • Enable/disable DHCP (was enabled while trying dhcpcd)
  • Set static IP address
  • Set network/subnet mask
  • Set static gateway IP

I've tried setting the static IP address to 192.168.99.1 and some ideas for the rest of the options, but wasn't sure what I should use. Perhaps some settings here or additional settings in ip addr could help? Or something else?

My computer is running Arch linux.

2

I solved it with the help from someone in the #archlinux IRC channel. My mistake was that I was trying to give enp0s16f1u1 the same IP address/mask as the phone adapter. In the end the following did the trick:

ip link set enp0s16f1u1 up
ip addr add 10.0.0.5/24 dev enp0s16f1u1

I then set the phone adapter as follows:

  • Disable DHCP
  • Static IP address: 10.0.0.6
  • Network/subnet mask: 255.255.255.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.