1

I'm running the following command:

sudo iwconfig wlan1 essid "wifi network"

I keep getting back:

SET failed on device wlan1 ; Operation not permitted.

On other computers there is no problem.

I'm wondering if I need to change the mode first? How can I go about debugging this issue?

  • What is your distro and what version? – user8779 Nov 6 '17 at 17:52
  • @arochester Ubuntu 14.04 on an embedded device – Philip Kirkbride Nov 6 '17 at 17:55
  • What mode/type is that interface (iw wlan1 show)? – dirkt Nov 6 '17 at 19:51
  • @dirkt when I use that command I get a long message about how to use iw as if it is the wrong syntax. pastebin.com/AGEq6pw4 – Philip Kirkbride Nov 6 '17 at 20:24
  • @dirkt on my laptop I can do iw <interface> info for devices shown on ifconfig but on the embedded device I get back command failed: No such device (-19) – Philip Kirkbride Nov 6 '17 at 21:04
0

I seemed to be able to fix the problem by putting the interface in ad-hoc mode:

sudo ifconfig wlan1 down
sudo iwconfig wlan1 mode ad-hoc
sudo ifconfig wlan1 up
sudo iwconfig wlan1 essid "wifi network"

Update: I tried the same process with auto, and managed which also worked. The mode master did not work.

|improve this answer|||||
  • 1
    But then the interface is in ad-hoc mode, and unless you have lots of other devices in ad-hoc mode and want to make a mesh, that's probably not the mode you want ... – dirkt Nov 6 '17 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.