1

I don't want to use the standard gpg version in raspbian which is almost 4 years old . I had to compile all the libraries manually . This worked fine but then when I compiled gpg it saied " libgcrypt too old need 1.7.0 have 1.6.4 " even tho I install libgcrypt 1.8.1 . So i uninstalled gpg and libgcrypt with " make uninstall " and compiled them again . With no success . I've tried to find a solution the last two days . There were some forum posts on the ubuntu forums , but they were not very helpful .

When I compild it the last time it gave out an error :

collect2: error: ld returned 1 exit status Makefile:949: recipe for target 't-stringhelp' failed make[3]: *** [t-stringhelp] Error 1 make[3]: Leaving directory '/home/pi/gnupg-2.2.1/common' Makefile:816: recipe for target 'all' failed make[2]: *** [all] Error 2 make[2]: Leaving directory '/home/pi/gnupg-2.2.1/common' Makefile:590: recipe for target 'all-recursive' failed make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory '/home/pi/gnupg-2.2.1' Makefile:509: recipe for target 'all' failed make: *** [all] Error 2
13
  • 2
    That's actually the least helpful part of the output. Nov 6, 2017 at 17:31
  • 1
    Doesn’t Raspbian have the gnupg2 package in version 2.1.18, which is ten months old? Nov 6, 2017 at 17:47
  • mybe that's better pastebin.com/KD5nsn0q Nov 6, 2017 at 17:47
  • No the gpg2 package is from 2013 Nov 6, 2017 at 17:48
  • 1
    @Richard, what RubberStamp is getting at is that even if you don’t have a test Pi, you can copy your SD card to another one, test the upgrade there and see if it suits you. If it doesn’t, switch back to the old SD card and you haven’t lost anything (apart from a little time). You’re the only person who can determine whether an upgrade is appropriate for you; we could tell you it would be, and I doubt Stretch removed anything you’d need, but I can’t know for sure. Nov 6, 2017 at 18:25

1 Answer 1

3

Converting comment to answer:

From your comments, you are using the oldstable version of Raspbian. You should be aware that the oldstable receives less frequent updates and is estimated to remain within the Debian security team's perview for about one year after the release of the next stable release.

See Debian's wiki on oldstable

As such, Debian oldstable shouldn't be used unless there is some special reason for it to remain in use. All Raspbian users should change their sources.list to reflect the release of the new stable version of Raspbian which is currently, Stretch

GNUPG 2.2 series is also the new stable for GNUPG. The 2.1 series and prior end support at the end of Dec 2017.

See GNUPG 2.2.0 Announcement

The GnuPG team is pleased to announce the availability of a new release of GnuPG: version 2.2.0. See below for a list of new features and bug fixes. This release marks the start of a new long term support series to replace the 2.0.x series which will reach end-of-life on 2017-12-31.

And GNUPG 2.2.1 Announcement

We are is pleased to announce the availability of a new GnuPG release: version 2.2.1. This is a maintenance release; see below for a list of fixed bugs.

As far as the question: "Will upgrading to Stretch break things?"

I would suggest getting a second SD card, installing the new stable version of Raspbian on that new card, and copying over any personal applications and data. This will allow you to test the new stable version while not disturbing your oldstable installation.

Addendum

Of course, this answer doesn't directly answer your question of "How do I build GNUPG?"

For a nice easy to follow answer to this question you can follow the instructions included on GNUPG's Webkey installation page:

GNUPG Webkey with local build of new version GNUPG

GNUPG Says:

The easiest way to install the latest GnuPG version is to use Speedo, which downloads, verifies and builds all dependent packages. To do this first unpack the tarball:

$ tar xjf gnupg-2.1.15.tar.bz2

On non GNU system you may need to use this instead:

$ zcat gnupg-2.1.15.tar.bz2 | tar xf -

Then run:

$ make -f gnupg-2.1.15/build-aux/speedo.mk INSTALL_PREFIX=. \
    speedo_pkg_gnupg_configure='--enable-gpg2-is-gpg        \
      --disable-g13 --enable-wks-tools' native

If you run into errors you are probably missing some development tools; install them and try again. If all succeeds you will notice a bunch of new directories below webkey's home directory:

PLAY bin include lib libexec sbin share swdb.lst swdb.lst.sig Optionally you may delete what is not anymore required:

$ rm -rf PLAY include lib swdb.*

To make use of your new GnuPG installation you need to run this first (you should add it to webkey's .profile or .bashrc):

PATH="$HOME/bin:$PATH"
LD_LIBRARY_PATH="$(pwd)/lib"
export LD_LIBRARY_PATH

End build instructions

Of course, you will be playing with the latest version of GNUPG which is no longer 2.1.15

1
  • It somehow worked but now I have another issue :/ . I will make another post about that . Nov 6, 2017 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.