1

I just finished building my LFS system, but been running into issues during the first boot. The error that comes up is:

hd1 cannot get c/h/s values

So a little background: The base machine I used was CentOS7 on a Virtual Machine running on ESX6. The sda was the drive for the base CentOS7 and a second drive for the LFS which is sdb. In this, sdb1 was my XFS / partition and sdb2 is my swap.

My Grub.cfg under /boot/grub/grub.cfg is:

# Begin /boot/grub/grub.cfg
set default=0
set timeout=5

insmod xfs
set root=(hd1,0)

menuentry "GNU/Linux, Test-Linux-1.0" {
        linux   /boot/vmlinuz-4.12.7-lfs-8.1 root=/dev/sdb1 ro
}

fstab entry is:

# Begin /etc/fstab

# file system  mount-point  type     options             dump  fsck
#                                                              order

/dev/sdb1     /             xfs    defaults            1     1
/dev/sdb2     swap         swap     pri=1               0     0
proc           /proc        proc     nosuid,noexec,nodev 0     0
sysfs          /sys         sysfs    nosuid,noexec,nodev 0     0
devpts         /dev/pts     devpts   gid=5,mode=620      0     0
tmpfs          /run         tmpfs    defaults            0     0
devtmpfs       /dev         devtmpfs mode=0755,nosuid    0     0

I tried changing to sda1 and sda2 in fstab and set root to sda1 in Grub along with hdd to 0,0 and still no luck.

Any thoughts? Thanks for the help.

  • 1
    Well, I was able to get past this. I had missed out on the VMXNET3 and SAS drivers. Lol, yeah I know! Now, it boots into grub> prompt. Not sure what's next. – suhas savkoor Nov 6 '17 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.