7

I can't invoke my bluetoothctl anymore. It waits for connections withouth success showing this in the terminal:

me@mashin:~$ bluetoothctl 
Waiting to connect to bluetoothd...

Any suggestion how to start the joyful debuging?

I am using Debian 9.2.

Edit

Output of sudo systemctl status bluetooth.service

● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset
   Active: inactive (dead)
     Docs: man:bluetoothd(8)
  • 2
    Please add the output of sudo systemctl status bluetooth.service to the question. – Ferenc Wágner Nov 7 '17 at 6:47
9

I had the same problem. I found a solution on archlinux.org's forums.

I had to load the kernel module btusb. To test if this will solve the problem for you, run as root :

modprobe btusb
systemctl start bluetooth

then test if bluetoothctl works. If it does you can make this fix permanent by loading the module on boot. To do that on Debian add (as root) the line:

btusb

at the end of the file /etc/modules.

You might also want to ask systemd to enable the bluetooth service on boot, in this case execute (as root):

systemctl enable bluetooth

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy