0

I installed Nitrux Os(Ubuntu Based) It's successfully connecting to Wifi or Wired connection but Internet ain't sending any traffic. Whenever I am trying to Open a website it is saying

This site can't be reached.

or Whenever I am trying to ping.It is saying :

Ping: www.google.com: Temporary failure in name resolution

Software Center and other Internet related applications are saying "No Internet Connection" even my system is connected to WIFI or Wired.

I tried to modify /etc/resolv.conf Nameserver from 127.0.1.1 to 8.8.8.8 and 8.8.4.4 but but Whenever I am restarting Network-Manager the Value of nameserver automatically setting back to default 127.0.1.1

Thanks in advance :)

  • What are the nameserver settings in your DHCP server? Are you using manually entered static IP addresses on your LAN? Can you access Internet sites just fine after manually setting nameservers? Can you ping your chosen nameservers directly using their IP addresses? – RubberStamp Nov 5 '17 at 15:35
  • @RubberStamp yes sir I can ping any nameserver using their IP address for Eg I tried to ping google public nameserver 8.8.8.8 and it worked fine but www.google.com or other domain failed with warning "Temporary failure in name resolution". – user8438226 Nov 6 '17 at 6:34
  • @RubberStamp I got this from 'nmcli' wlp2s0b1: connected to WiFiName "Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter" Wifi (brcmsmac), B4:74:9F:**:**:**, hw, mtu 1500 ip4 default inet4 192.168.43.123/24 inet6 fe80::d714:****:****:fde4/64 enp4s0: unavailable "Realtek RTL8111/8168/8411 PCI Express Gigabyte Ethernet Controller" ethernet (r8169), E8:11:32:**:**:**, hw, mtu 1500 lo: unmanaged "lo" loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536 DNS Configuration : servers : 192.168.43.1 interface : wlp2s0b1 – user8438226 Nov 6 '17 at 6:35
0

Add the following line:

prepend domain-name-servers 8.8.8.8, 8.8.4.4;

To your :

/etc/dhcp/dhclient.conf

The human-readable domain www.google.com will be transformed into an IP address allowing the ping www.google.com.

See Example on Configure your network settings to use Google Public DNS

0

From your response in the comments, it looks like everything is working fine, but you need to set your preferred nameservers for your computer.

There are multiple ways of setting the preferred nameservers. You can set them directly on your computer by using the method detailed by GAD3R. Or, you can set your router's nameserver settings which will propagate those settings to each host in your network that receives a DHCP lease from your router.... Or, you can edit the /etc/resolv.conf, as you did, for temporary changes.

My preferred method is to set the nameservers via the DHCP server: in your case, via the probable web interface on your wifi router at 192.168.43.1 ... Of course, this method is only possible if you have access to the router's settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.