4

on my Raspberry Pi I have a SD card with noobs and an installed Raspbian. Everything went fine without any problems, it was booted directly into the raspbian. Now I made a wrong entry in the fstab and booting was no longer possible. "root locked unable to mount /mnt/server...". kind of like that, anyway. Now I put the SD in a laptop with Linux mint and commented out the wrong line with sudo nano /etc/fstab. Back to my RPi now the recoverymenu of noobs comes with "select an os to boot" but the window is empty. Even when enforcing Recovery (Shift key), it no longer recognizes that Raspbian is installed. Before editing fstab, he had recognized this.

Is there any way to fix that? like fixmbr to boot directly into the raspbian?

More data:

fdisk -l

Gerät      Boot   Start     Ende Sektoren Größe Id Typ
/dev/sdb1          8192  3275390  3267199  1,6G  e W95 FAT16 (LBA)
/dev/sdb2       3275391 15757311 12481921    6G  5 Erweiterte
/dev/sdb5       3276800  3342333    65534   32M 83 Linux
/dev/sdb6       3342336  3483647   141312   69M  c W95 FAT32 (LBA)
/dev/sdb7       3489792 15757311 12267520  5,9G 83 Linux

Screenshot gparted

proc            /proc           proc    defaults          0       0
/dev/mmcblk0p6  /boot           vfat    defaults          0       2
/dev/mmcblk0p7  /               ext4    defaults,noatime  0       1
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that
# //j6p-w7-srv/R    /mnt/server cifs username=joe6pack,password=xxxxxxxxxxxxx,file_mode=0666,dir_mode=0666 0 0
# https://webdav.magentacloud.de /mnt/webdav davfs user,rw,file_mode=0777,dir_mode=0777,gid=davfs2 0 0 

the line with /mnt/server was the problem

this is the fstab from the last partition sdb7 (mmcblk0p7)

here the cmdline.txt from sdb6 (mmcblk0p6)

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
  • Please also add the contents of the fstab file on the SD card. – DopeGhoti Nov 3 '17 at 22:06
  • When you say that on the Mint box you did sudo nano /etc/fstab you meant of course nano /path/to/the/sd/card/etc/fstab, yes? That is, you didn't edit the Mint box's fstab, but the fstab on the SD card? – AlexP Nov 4 '17 at 0:07
  • Yeah, that's what I meant, of course. The SD was mounted as media/joe6pack/root and there I changed the fstab. But I just solved the problem and I'm writing an answer right now. – Joe6pack Nov 4 '17 at 0:27
  • but one problem remains: the mounting of the shares. I added _netdev to the lines, now at least the boot process doesn't hang. But the shares are not mounted. not even after the system boots completely. What am I doing wrong? sudo Mount -a works – Joe6pack Nov 4 '17 at 0:46
2

I solved it: The problem was a corrupted file in the SETTINGS mount point. There is a file called: installed_os.json. This one was defective. For whatever reason. As a result, NOOB's could not find any installed Linux and so the selection window remained empty. The following content had to be in my case included:

[
 {
  "description" : "A Debian wheezy port, optimised for the Raspberry Pi",
  "folder" : "/mnt/os/Raspbian",
  "icon" : "/mnt/os/Raspbian/Raspbian.png",
  "name" : "Raspbian",
  "partitions" : [
"/dev/mmcblk0p6",
"/dev/mmcblk0p7"
  ],
  "release_date" : "2014-01-07"
 }
]

now NOOB's knew about an already installed linux and was able to boot without any problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.