2

This is a follow up question to this Q/A.

I tried the command on my laptop it worked:

setfacl -m 'u:programX:rwx' /etc/NetworkManager

I checked that my embedded device had acl installed and marked correct.

But I'm finding when using the command on the embedded device I get setfacl: /etc/NetworkManager: Operation not supported.

When I check man setfacl my version of acl seems to support the -m flag.

Why wouldn't acl on the device support the operation, when it works fine on my laptop?


Result of mount | grep -w /:

/dev/block/mtd/by-name/linuxroot on / type ext4 (rw,relatime,barrier=1,data=ordered)
  • What's the output of mount | grep -w / ? – Mark Plotnick Nov 3 '17 at 20:30
  • @MarkPlotnick added to question – Philip Kirkbride Nov 3 '17 at 20:31
  • What is the output of tune2fs -l /dev/sdaX | grep "Default mount options" replace sdaX with your device. – GAD3R Nov 3 '17 at 20:57
  • @GAD3R it returns tune2fs: No such file or directory while trying to open /dev/sdaX Couldn't find valid filesystem superblock – Philip Kirkbride Nov 3 '17 at 21:07
  • @PhilipKirkbride GAD3R specifically mentioned to replace sdaX with your device, hence try tune2fs -l /dev/block/mtd/by-name/linuxroot | grep "Default mount" – oneindelijk May 21 at 10:43
7

The ext4 code in older kernels (I do not know until when) needs acl as mount option. So you may try:

mount -o remount,acl /

/etc/fstab

Your fstab contains a line like

/dev/sda3   /  ext4    defaults    0 0

You have to add acl to the options field:

/dev/sda3   /  ext4    defaults,acl    0 0
  • I ran remout but still same result – Philip Kirkbride Nov 3 '17 at 20:48
  • 2
    @PhilipKirkbride Does mount | grep -w / now show acl? Can you add acl to the fstab entry and reboot? – Hauke Laging Nov 3 '17 at 20:53
  • It doesn't show acl I will update fstab. – Philip Kirkbride Nov 3 '17 at 20:55
  • Can you leave short note on updating fstab I haven't done that before. – Philip Kirkbride Nov 3 '17 at 20:56
  • 1
    @PhilipKirkbride See the edit – Hauke Laging Nov 3 '17 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.