1

I'm using VirtualBox Version 5.0.40_Ubuntu r115130 on a linux mint mate (18.2) host. I have also installed Oracle VM VirtualBox Extension Pack Version 5.0.40r115130. I installed a Windows 7 Ultimate (64bit) guest OS. I also added my current user to the vboxusers group.

The problem is that when I select USB3.0 (xchi) in my USB settings, from my guest I go to Devices>USB and select the USB device I want to load it gets unmounted from my host OS but does not mount in my guest OS.

I tried adding a 'USB Device Filter' from my guest settings but nothing. I have searched for solutions online and tried these Cannot see usb devices on Windows guest, How to set up USB for Virtualbox?, VirtualBox/USB amoung others but none seem to solve my problem.

Further digging and I saw that in my guest OS I do not have any USB drivers installedDevice Manager

I have also installed other linux-based guest OS and they have no problems seeing USB devices. Also if I select USB 2.0 in my USB settings the devices work perfectly but at USB 2.0 speed.

Any help on this matter would be greatly appreciated.

5
  • 1
    Do you have the VirtualBox Guest Additions installed in your Windows 7 VM? I'm not sure if it is needed for USB functionalities, but it is always recommended to have it installed. Nov 3, 2017 at 20:03
  • Yes @eduardo, I do have guest additions installed on the guest OS. I edited the question after trying out some other variants and noticed that it does work if I select USB 2.0 (echi) in the USB settings.
    – natral
    Nov 3, 2017 at 21:20
  • 1
    have you tried to install the USB 3.0 drivers in your Windows 7 Guest? Nov 5, 2017 at 23:31
  • 1
    Thanks for the link @eduardo. I tried previously with the most recent of the 2 drivers but had no luck. However I tried with the driver dated 2014 and seems to be working so far. Thanks for all the help.
    – natral
    Nov 6, 2017 at 15:23
  • Oh, good news :) @natral To help others with the same problem, it would be nice to answer your own question with the solution, then accept the answer. Nov 6, 2017 at 15:49

3 Answers 3

4

I have had a few hiccups during the process but I finally have everything up and running. Here I will lay details on how I managed to get my guest machine set up so that it can access my USB devices.

  1. First I installed VirtualBox using apt-get install virtualbox

  2. Next I downloaded and installed Oracle_VM_VirtualBox_Extension_Pack-5.0.40-115130.vbox-extpack and VBoxGuestAdditions_5.0.40.iso from the VirtualBox official download page.

Note that, depending on the version of VirtualBox you are running, you need to get the appropriate extension pack and guest additions.

  1. Now you need to add the current user to the vboxusers group using the following command:

     sudo usermod -aG vboxusers "$USER"
    

This command adds the current user to the vboxusers group. If you wish to add other users to this group substitute $USER for the username of the desired user.

  1. Up to this point you should be able to use USB 2.0 devices on your guest machine by accessing the “Devices” → “USB” menu from your guest machine. In my case this selection was enough, but sometimes there can be problems if the device is not unmounted properly from the host before loaded into the guest OS. If this is the case, in the USB settings section you can create a USB filter for the device which will load it automatically in your guest OS once it is running.

  2. In the case of Windows 7, USB 3.0 drivers are not installed with the OS and require manual installation. They can be found here. In my case the drivers that worked were the ones dated 2/3/2014, the more recent drivers were not compatible with my guest OS.

After this my USB 3.0 devices worked perfectly in my guest OS.

Special thanks to Eduardo Baitello for his assistance.

2
  • I would add to logout after addin user to group
    – Ferroao
    Jun 13, 2019 at 17:26
  • edited the answer to point future me to the Internet Archive for downloading the correct USB 3.0 drivers for win 7 in VBox 6.1.
    – BISI
    Jun 29, 2022 at 23:23
1

An old post but I just fixed a similar problem. My usb 2.0 yeti mike and g13 game pad did not work on my newly installed win 7 guest but worked fine on an a bloated win 7 guest that I deleted. I pulled my hair out for days troubleshooting the vb, sound settings, usb settings etc. Finally I saw a post here about usb 3.0 drivers which I downloaded directly from Intel. Poof..problem solved. The usb hub was plugged into a usb 3 port and I failed to realize that I had installed the drivers from a mobo setup disc!!

Anyone using a win 7 guest please download the USB 3 drivers!

2
  • The given Link is not avaible anymore on the Intel Homepage for download
    – tomy
    Oct 6, 2020 at 9:09
  • edited the answer to point to the copy at the internet archive
    – BISI
    Jun 29, 2022 at 23:21
0

After i updated my virtual box i had this problem.

  1. first make sure you have installed vbox_aditional_extention_pack on host and guest.

  2. Then install Driver from Intel, which is not exists any more.

i found a solution here Which suggested an Archived link :

Download from Web Archive Here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .