I have installed OpenSuse at work, and my admin fixed some problems with my login. The login worked at work, I also restarted PC and tried it after restart, it was fine too. But then I came home I couldn't login (both GUI and terminal doesn't work), it says "No logon servers". I thought that's only a problem at home, but I tried it at work and I'm getting the same message.

Login as root works, but my login not.

How can I try to fix the "No logon servers" problem?

  • When you say PC are you talking about a notebook or you are carring your PC from home to work? or you have installed OpenSUSE on two diferent machines?... check the permision of you users with yast if you can login as root – maniat1k Jun 12 '12 at 17:59

It sounds like you are authenticating with Active Directory. When you move to your home network, your AD controller isn't present so Samba doesn't know what to do.

Why does it still gives that message when you return to work? No idea, but my guess is there is a cache somewhere that needs to be flushed.

A quick DuckDuckGo search for flushing samba's winbind cache is here.

I'd make sure to make a backup before hand.

NOTE: I'm only assuming that it's using Active Directory, because I've seen a similar error on Windows machines, and the usual response has been to remove them from the domain and rejoin them.


The answer is "go ask your admin".

The reason you're getting this message is because something outside of your system is not what your system expects. There's no way we can diagnose the external network, knowing nothing about it. And there's no way we can diagnose why that message is coming up without knowing the authentication mechanisms configured on your system. It's obviously significantly different than the default. It would be dangerous to follow any advice someone gives based on as little information as you provided.

You have a resource that does know about it already. You should use it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.