-1

I swapped out a MacBookPro running OS X and Terminal.app - for a Windows 7 box using Putty.

ctrl-F no longer works on my shell prompts to move the cursor forward within a command line I'm editing: I don't see any obvious settings in putty that are overriding ctrl-F being passed through to the terminal, and I don't see any obvious settings on the Unix terminal side that would not pass that raw character. I don't want Windows to intercept any ctrl characters, since the terminal program (putty in this case) needs those.

All of the other keystrokes work as expected: ctrl-A goes to the beginning of the line ctrl-R reverse searches the bash history

stty settings % stty -a speed 38400 baud; rows 24; columns 80; line = 0; intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = ; eol2 = ; swtch = ; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0; -parenb -parodd -cmspar cs8 -hupcl -cstopb cread -clocal -crtscts -ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel iutf8 opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0 isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke

Putty version is PuTTY Release 0.69-1 Build platform: 64-bit Windows Compiler: Visual Studio, unrecognised version (_MSC_VER=1910) Source commit: deadbeefdeadbeefdeadbeefdeadbeefdeadbeef © 1997-2017 Simon Tatham. All rights reserved. Any suggestions appreciated

  • This is not a unix/linux question. – Lizardx Nov 3 '17 at 16:24
  • Execute read -n 1 and then press ^F. Do you see any output? – Hauke Laging Nov 3 '17 at 16:39
  • $ read -n 1 No output. I'm thinking that windows might have grabbed it, but there is no visual feedback from putty either. – user66924 Nov 3 '17 at 17:29
  • Do not put the answer in the question. Make it a real answer. Otherwise this questions still looks unanswered. – Hauke Laging Nov 3 '17 at 20:47
1

The solution was another post in superuser.com - the new putty installation had a terminal setting that needed to be changed to 'linux' rather than the default setting of 'xterm'

https://superuser.com/questions/94436/how-to-configure-putty-so-that-home-end-pgup-pgdn-work-properly-in-bash/104001#104001

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.