3

Maybe it serves to describe my current situation first:

  • installed ubuntu on virtualbox (btrfs)
  • created btrfs partition on my laptop
  • booted on a live distro, used btrfs send/receive to transfer the root subvolume from the virtualbox
  • set up grub so I can now boot my laptop from the ubuntu subvolume

The problem that arises: I can boot ubuntu, but I cannot reboot or shutdown the system. Whenever I click shutdown, or issue a 'shutdown now' command, the system freezes completely. I have a feeling that this is because ACPI is not installed, but I'm in doubt why this could be. Does the ubuntu installation detect that virtualbox does not need ACPI, so it does not add it? I have verified that no acpi service is running in the distro.

I have done this for an ubuntu 16.04 and an arch installation, both with the same conclusion / problem. My question is: is this really because of ACPI? Am I missing some other functionality due to this transfer of virtual to physical? Is the problem solved by simply installing ACPI packages in ubuntu / arch?

  • Have you checked dmesg from the previous boot? – Outurnate Nov 2 '17 at 23:16
  • there were some references in dmesg to ACPI. A number of errors: [ 0.037510] ACPI Error: [_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20170531/dswload-210) [ 0.037517] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170531/psobject-252) [ 0.037556] ACPI Exception: AE_NOT_FOUND, (SSDT:xh_rvp11) while loading table (20170531/tbxfload-228) [ 0.040342] ACPI Error: 1 table load failures, 12 successful (20170531/tbxfload-246 some additional output, references to the power button/battery/... and then a number of loaded modules – CountZukula Nov 3 '17 at 12:10
  • In the arch subinstallation: installed acpid and gnome. Now the system shuts down, I guess it's due to the acpid service being active. Still it's strange to me that the installation would hand pick the ACPI service as something unnecessary in the virtualbox install? – CountZukula Nov 3 '17 at 12:37
  • however, in ubuntu, after making sure acpid is enabled and running, a reboot command will instantly lock up the machine. So I guess something else is still going on... – CountZukula Nov 3 '17 at 13:04
  • As for the success in arch: the installation of gnome had nothing to do with it. I retried, after installing gnome+gnome-extra the system didn't reboot either. After a hard reboot, installed acpid, enabled / started the service. Then did reboot, the system hangs again. – CountZukula Nov 3 '17 at 13:15
0

The hard lock @reboot or @shutdown time was apparently caused by the graphics drivers of my laptop not yet being loaded. Installing the drivers fixed the problem. Hopefully someone is helped by this, avoiding some sidetrack time on the ACPI path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.