Currently I am using two DNS server, one as a master, one as a slave. Both of them are working nice. Both of them are RedHat5, the master is running the version of named: BIND 9.3.4-P1, the slave is running: BIND 9.3.3rc2.

Now I have enabled a freshly installed server, CentOS7, running the version: BIND 9.9.4-RedHat-9.9.4-51.el7 (Extended Support Version)

I have configured it as a slave, and all the time it tried to update the zonefile, it failed with syntax error:

named[26484]: zone gab.bi/IN: refresh: retry limit for master exceeded (source
named[26484]: zone gab.bi/IN: Transfer started.
named[26484]: transfer of 'gab.bi/IN' from connected using
named[26484]: transfer of 'gab.bi/IN' from failed while receiving responses: syntax error
named[26484]: transfer of 'gab.bi/IN' from Transfer completed: 0 messages, 0 records, 0 bytes, 0.005 secs (0 bytes/sec)`

I have decided to only keep one record, and check it with the zonechecker, to see what is going on. The one-record db file looks like the one below:

$ORIGIN gab.bi.
000200b3009ge            A
                        TXT     "1509653923"
                        NAPTR   0 0 "GAB-62110" "v0 19275379 2.28" "4:7:18:30.36" 1509653923.

Running the named-checkzone resulted the following, so there is a problem with the NAPTR record.

-# named-checkzone gab.bi /etc/named/db.gab
dns_rdata_fromtext: /etc/named/db.gab:15: syntax error
zone gab.bi/IN: loading from master file /etc/named/db.gab failed: syntax     error
zone gab.bi/IN: not loaded due to errors.

It is quite strange, that it is running fine on the master, the "old" slave was able to update his dbfile using the format described above, but it fails using a newer version of named.

Your help is highly appreciated.


Your NAPTR is clearly wrong. Have a look at RFC2915. To start with, after order and preference the first string is related to flags. You have "GAB-62110" where the flags can be only S, A, U or P. So without even reading further we see your record is invalid, as the tool say. But it is also easy to see that the following parts of the record are wrong too. You will have to fix your record.

And are you sure you reloaded the master? Because it would have failed in the same way due to the same syntax error but if you look at logfiles you will see that it may have continued using the old zone content as the new one is invalid.

  • I have tried the same DB file on bith system, using the named-checkzone the older just ran fine, but the newer one failed with syntax error. Still checking it. – GABIKA6 Nov 3 '17 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.