1

When I play audio on my aux headphone output, when the master-volume is 0% no sound is heard, no problem there. However, when I go to 1% or anything between that and 100%, the volume is at 100%, and doesn't change in audible volume/db, until it goes over 100%, like 115% it's audibly louder.

So basically the audio goes from 0 to 100. While the internal sound volume (it's a laptop) works fine. And it switches between them automatically fine when I plug in a headphone.

Also, this is not a an issue with the hardware itself, because this has work normally before and still works fine with windows 10. (I think it even might have something to do with i3, because I think it worked fine with Cinnamon)

I've tried googling this issue, but I can't find any prior cases or the right search terms to use.

When I open pavucontrol I can control the volume there per application, that is the only way to control the volume, but not with the master volume.

This might help:

❱ inxi -Fxz
System:    Host: me2 Kernel: 4.10.0-35-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: i3 4.14.1 Distro: Linux Mint 18.2 Sonya
Machine:   Mobo: Micro-Star model: MS-17B1 v: REV:1.0
           Bios: American Megatrends v: E17B1IMS.310 date: 04/07/2017
CPU:       Quad core Intel Core i7-7700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
           clock speeds: max: 2700 MHz 1: 2800 MHz 2: 2800 MHz 3: 2800 MHz 4: 2800 MHz
           5: 2800 MHz 6: 2800 MHz 7: 2800 MHz 8: 2800 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA Device 1c20 bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1920x1080@60.00hz, 3840x2160@60.00hz, 1920x1080@59.93hz
           GLX Renderer: GeForce GTX 1060/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 375.66 Direct Rendering: Yes
Audio:     Card Intel Device a171 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.10.0-35-generic
Network:   Card-1: Qualcomm Atheros Device e0b1 driver: alx port: d000 bus-ID: 3d:00.0
           IF: enp61s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 3e:00.0
           IF: wlp62s0 state: down mac: <filter>
           Card-3: Atheros usb-ID: 001-007
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 2000.4GB (5.6% used)
           ID-1: /dev/nvme0n1 model: N/A size: 512.1GB
           ID-2: /dev/sda model: ST2000LM015 size: 2000.4GB
           ID-3: /dev/mmcblk0 model: N/A size: 124.5GB
Partition: ID-1: / size: 119G used: 17G (15%) fs: ext4 dev: /dev/nvme0n1p5
           ID-2: /home size: 67G used: 60G (94%) fs: ext4 dev: /dev/nvme0n1p7
           ID-3: swap-1 size: 32.00GB used: 0.19GB (1%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 62.5C mobo: 27.8C gpu: 0.0:48C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 392 Uptime: 1 day Memory: 12399.8/15929.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (zsh 5.1.1) inxi: 2.2.35 

Output of pacmd info: https://gist.github.com/anonymous/e1911641574d8a511fc4d7e2d09d5c3f

A more extensive thread of this problem: https://forums.linuxmint.com/viewtopic.php?f=48&t=256467&p=1385313#p1385313 see the replies.

So in summary

  • The internal speakers don't mute when I plug in the headphones (this is a different issue than this post)
  • The internal speakers work fine with the master volume.

  • The AUX output is not shown in Output Devices which might be the main problem here.

  • The AUX volume only changes when the main volume is above 100%
  • The AUX volume can only be changed by changing the volume of the source app, or under the Playback tab in pavucontrol.

  • Under configuration tab in pavucontrol the profile Analogue Stereo Duplex or Analogue Stereo Output gives me sound through the AUX, the others don't

  • does the command line work : pactl set-sink-volume 0 -50% or pactl set-sink-volume 0 +50%? – GAD3R Nov 2 '17 at 16:00
  • @GAD3R, yes and it will do the same thing as my master control is now doing. In Pavucontrol, the "pop" sound I hear when I manually move the slider, will also be the same volume, except above 100% – TrySpace Nov 2 '17 at 17:19
  • I solved the output problem Selecting Digital Stereo (IEC958) Output will mute my speakers, and the master volume will work on the AUX. For some reason the Output Devices port will say S/PDIF, while it is not an optical plug, just a stereo jack. Anyways, now I'll just need to find a way to detect the plugging in of the AUX which is a different topic entirely. I hesitate to close the issue, since the 0 to 100% is still strange and not expected behaviour. – TrySpace Nov 24 '17 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.