1

For a couple of days I'm facing a weird issue before that everything was working fine but now the Pulse Audio won't autostart at boot and the sound icon is missing from a panel as well. When I try to go to the Sound Settings there's no any Output or Input device listed, neither onboard audio nor my discrete sound card. So I execute this command in terminal:

rm -r ~/.pulse ~/.pulse-cookie ~/.config/pulse

And the sound appears right away. I tried to reinstall pulseaudio but it doesn't seem to help. Pulse Audio is listed in Settings / Autostart Applications and I din't make any changes to it.

What could be causing this?

Just to notice the sound icon is visible at user login window.

1

Well, the issue is solved.

I'll give a little explanation of what had happened or might happen to future readers. After the installment of discrete audio card I went into the Sound Settings where I checked my Analog Outputs and Analog Inputs, so as I have Xonar DG sound card which is by default aimed for 5.1 Surround Sound and I have 2 Speakers available at the moment I tried to change it in the settings to the most suitable option for me which was 4.0 Surround R,R,L,L out of the 2 options available 5.1 or 4.0. So I selected 4.0 and after system reboot the sound didn't load at boot that what was causing this issue but if you select / leave 5.1 Surround as a default Output the sound will load normally but on a 2.0 Speakers you'll be missing voice speech for e.g. in the movies recorded with 5.1 Sound.

So for the further notice to those who are using or will be using 2 Speakers on a 5.1 or 7.1 Surround sound card for the Settings options, etc. use your Output sink as the default Output for the Headphones that's the Output for Analog Stereo sound as well.

  • I very much doubt "the sound didn't load at boot". Probably Pulseaudio and the ALSA drivers did load, but there was no default profile for this configuration (or whatever went wrong). If that was case, you could have fixed it with a custom profile in /usr/share/pulseaudio/alsa-mixer/profile-sets/. Possibly it was also something else. – dirkt Nov 1 '17 at 6:49
  • The thing is that it didn't even detect any sound device at all and pavucontrol didn't respond as well. I'm not sure maybe it's a bug, I tried it multiple times and the same thing happened. – JoKeR Nov 1 '17 at 19:42
0

1-Open Your Terminal

>cd
~>nano .xprofile

add this line to your file

pulseaudio --start

save your file and reboot

  • Thank you. But it won't help in this case. Read my answer. – JoKeR Nov 1 '18 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.