0

I'm unable to reach a local Raspberry Pi server (192.168.0.155) on my home network over Ethernet, though I can ssh to it perfectly fine over wifi.

I have internet connectivity just fine through both interfaces, and the same behaviour occurs on another Macbook (can reach the server via wifi, but not through ethernet).

All ethernet cables simply run in to my home router (running DD-WRT), which also serves as the wireless access point.

Here's my netstat -rn output when using ethernet (through a Thunderbolt dock) from my Macbook Pro (192.168.0.176):

Destination        Gateway            Flags        Refs      Use   Netif Expire
default            192.168.0.1        UGSc           89        0     en6
127                127.0.0.1          UCS             1        0     lo0
127.0.0.1          127.0.0.1          UH              3      397     lo0
169.254            link#4             UCS             1        0     en6
192.168.0          link#4             UCS             4        0     en6
192.168.0.1/32     link#4             UCS             2        0     en6
192.168.0.1        c4:6e:1f:7f:1a:3e  UHLWIir        90     9350     en6   1199
192.168.0.131      94:53:30:47:2:c9   UHLWIi          1        0     en6    470
192.168.0.155      link#4             UHLWIi          1        7     en6
192.168.0.176/32   link#4             UCS             1        0     en6
192.168.0.255      link#4             UHLWbI          1       72     en6
224.0.0            link#4             UmCS            2        0     en6
224.0.0.251        1:0:5e:0:0:fb      UHmLWI          1        0     en6
255.255.255.255/32 link#4             UCS             2        0     en6
255.255.255.255    link#4             UHLWbI          1       28     en6

And when connected to wifi:

Destination        Gateway            Flags        Refs      Use   Netif Expire
default            192.168.0.1        UGSc           27        0     en0
127                127.0.0.1          UCS             1        0     lo0
127.0.0.1          127.0.0.1          UH              2      397     lo0
169.254            link#5             UCS             1        0     en0
192.168.0          link#5             UCS             3        0     en0
192.168.0.1/32     link#5             UCS             2        0     en0
192.168.0.1        c4:6e:1f:7f:1a:3e  UHLWIir        29      119     en0   1198
192.168.0.150/32   link#5             UCS             1        0     en0
192.168.0.155      b8:27:eb:b6:4c:34  UHLWIi          1        0     en0   1143
192.168.0.255      link#5             UHLWbI          1       26     en0
224.0.0            link#5             UmCS            2        0     en0
224.0.0.251        1:0:5e:0:0:fb      UHmLWI          1        0     en0
255.255.255.255/32 link#5             UCS             2        0     en0
255.255.255.255    link#5             UHLWbI          1        2     en0

And ifconfig output:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 ::1 prefixlen 128 
    inet 127.0.0.1 netmask 0xff000000 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    nd6 options=1<PERFORMNUD>
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en6: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    options=b<RXCSUM,TXCSUM,VLAN_HWTAGGING>
    ether 00:0c:6c:07:66:ba 
    nd6 options=1<PERFORMNUD>
    media: autoselect (<unknown type>)
    status: inactive
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 80:e6:50:0a:78:ea 
    inet 192.168.0.150 netmask 0xffffff00 broadcast 192.168.0.255
    media: autoselect
    status: active
en1: flags=963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX> mtu 1500
    options=60<TSO4,TSO6>
    ether 72:00:04:b0:66:30 
    media: autoselect <full-duplex>
    status: inactive
en2: flags=963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX> mtu 1500
    options=60<TSO4,TSO6>
    ether 72:00:04:b0:66:31 
    media: autoselect <full-duplex>
    status: inactive
p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
    ether 02:e6:50:0a:78:ea 
    media: autoselect
    status: inactive
awdl0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1484
    ether da:51:ce:04:6b:fd 
    inet6 fe80::d851:ceff:fe04:6bfd%awdl0 prefixlen 64 scopeid 0x9 
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active
bridge0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    options=63<RXCSUM,TXCSUM,TSO4,TSO6>
    ether 02:0c:6c:70:dc:00 
    Configuration:
        id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
        maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
        root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
        ipfilter disabled flags 0x2
    member: en2 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 7 priority 0 path cost 0
    member: en1 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 6 priority 0 path cost 0
    media: <unknown type>
    status: inactive
utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1380
    inet6 fe80::818d:c5f0:c295:5130%utun0 prefixlen 64 scopeid 0xb 
    inet6 fd1b:90c8:de38:d6b:818d:c5f0:c295:5130 prefixlen 64 
    nd6 options=1<PERFORMNUD>

I've reset routes a number of times, restarted the laptops and router, and changed the IP on the Pi server but the problem persists.

  • 1
    Have you checked the router's VLAN configuration already? This is a feature that can be configured. – sborsky Oct 31 '17 at 6:06
  • @sborsky My router doesn't have VLAN support. – sheldonbaker Oct 31 '17 at 16:06
  • 1
    tcpdump on the pi, on the Wi-Fi devices and on ethernet devices to see which packages reach where. Confirming mac addresses and the arp table (arp -a) on all devices can give you insight if packages are being sent to the correct device / IP. – Zip Nov 1 '17 at 0:21
  • Solved all this infuriating mess by just buying a new router. – sheldonbaker Nov 23 '17 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.