2

This question already has an answer here:

what I want to achieve is to install Firefox beta channel to update the current version so after running this command

sudo apt-repository ppa:mozillateam/firefox-next

I got this error

sudo: apt-repository: command not found

I've searched a lot to fix this, I found to fix this is to install

sudo apt-get install python-software-properties

which is printing the following

Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-software-properties is already the newest version (0.96.9debian1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

and I've tried what is mentioned in this thread and nothing worked. I can't find any solution for this.

marked as duplicate by G-Man, Stephen Rauch, Satō Katsura, Raphael Ahrens, DarkHeart Nov 1 '17 at 1:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @arochester nothing solved my issue from the mentioned thread – Mohamed Ibrahim Oct 30 '17 at 21:37
  • So, you installed the 'software-properties-common' package and tried the command I gave below? What distro and version are you using, btw? – Time4Tea Oct 30 '17 at 21:40
  • @Time4Tea 'software-properties-common' gives me the same error, and 'python-properties-common' is already installed I'm using Deepin 15.4.1 – Mohamed Ibrahim Oct 30 '17 at 21:42
2

Have you tried:

sudo add-apt-repository ppa:mozillateam/firefox-next

I believe that is the correct command.

  • this is causing the same error – Mohamed Ibrahim Oct 30 '17 at 21:32
  • What do you get if you type: which add-apt-repository ? – Time4Tea Oct 30 '17 at 21:41
  • nothing .. it runs with no message printed – Mohamed Ibrahim Oct 30 '17 at 21:43
  • It prints nothing at all? No output or error? Bizarre. What about if you try 'which grep' or 'which cat' (something that should obviously work)? – Time4Tea Oct 30 '17 at 21:48
  • 1
    @Bahamut I was talking to him in chat and software-properties-common didn't seem to be in his distro's package list. – Time4Tea Nov 2 '17 at 16:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.