1

How can I run applications from terminal?
For some applications I can find the path/name using which or whatis: which python or whatis mathematica or whatis math, but I can't run them by typing mathematica or math.
However, python works fine and I don't know what command I should give to chromium to run it. I can give a command to tor-browser to run in terminal, though.

I am using Debian Stretch with Gnome desktop.

0

6 Answers 6

5

Try chromium-browser.

If that doesn't work, issue the command dpkg-query -L chromium to list all the files installed during installation of chromium browser. One of these files will be your binary.

2
  • chromium-browser worked for LinuxMint 18, dpkg-query -L chromium-browser worked, but dpkg-query -L chromium returned nothing. May 6, 2020 at 16:10
  • Note that chromium-browser is an Ubuntu-specific thing they do to distinguish the version shipped in form of a Snap from the version that is distributed as a Debian package. You can actually install them both in parallel. On Debian stretch, which is used by the OP, the name is just chromium. Jul 9, 2020 at 1:01
2

To start the chromium web browser in ubuntu, try the following command :

chromium

Please note it is just chromium and not chromium-browser

2
1

Find the actual name of your application and then type it in the terminal:

chromium-browser

If you've run the application from GUI before, right-click the name in the menu and you should see the command/path of the application under Properties. That is where the actual name could be found as well.

Or you could search for it using find or apt-cache search or ...

Or maybe you have to add its location to PATH.

PATH=$PATH:/path/to/chromium

The world is full of options.

1
  • Thank you slybloty. I was looking for that, right click and command. I can find paths of many (almost all installed programs with it).However there occurs the problem when I try to do that with Mathematica in /bin/sh/usr/local/Wolfram/Mathematica/11.2/Executables, right clicking does not show the dialogue box with "command" in it. The dialogue box which appears has no "command" line/section. However, I found a path where there is a Mathematica icon, when I right click on it, it shows the command which I can use to run it from terminal. Path was /usr/share. Nov 2, 2017 at 1:45
0

Note that on Unix systems you have a few options when it comes to calling executables:

  1. You can type the full path. For example

    $ /usr/bin/nano
    
  2. You can type a relative path. For example

    /usr/lib$ ../bin/nano
    

    There is a common pitfall for Unix newbies: If you want to call an executable from the current working directory you have to say

    /usr/bin$ ./nano
    

    Note that this is different from Windows where you don't need the ./ (on the up side these two additional characters can often prevents surprises).

  3. You can just type nano in which case it will be searched in the directories specified by your PATH environment variable. This pattern should work for all programs installed as packages.

    If it doesn't work check your search path. Here's what I get as a regular user on my machine:

    $ echo $PATH
    /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
    

    Note that the search path for privileged users (root) typically includes additional directories like /usr/sbin containing executables that usually aren't too useful for regular users.

0

To start up a program, you need the package name (eg. python, chromium-browser, etc.), it's what you typed when you installed the program from terminal. To start it, just type the package name. If you don't know the name, google it, or use dpkg -l | less, and search the package names for to one you want using the arrow keys. Press q to exit.

2
  • 1
    Note that the name of the executable might differ from the package name. Jul 9, 2020 at 1:27
  • @martin Noted. By the way, if that's so, just google the executable name.
    – user421776
    Jul 9, 2020 at 15:05
0

On Raspberry Pi Ubuntu I did this to start a webpage, fullscreen (in Kiosk mode):

# put in ~/.bash_profile
DISPLAY=:0 chromium-browser --app=https://your.website —kiosk &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.