1

I have an email server with public dns entry that sends and receives fine.

I am trying to add it to outlook as imap account but it keeps failing. Server error shows

Oct 30 15:29:04 mail.example.local dovecot[17250]: imap-login: Disconnected (auth failed, 1 attempts in 4 secs): user=<user@example.local>, method=PLAIN, rip=12.123.456.789, lip=123.4.56.7, session=<yjdfyjfkugih>

Oct 30 15:29:08 mail.example.local auth[17491]: pam_unix(dovecot:auth): check pass; user unknown

cat /etc/pam.d/dovecot
#%PAM-1.0
auth       required     pam_nologin.so
auth       include      password-auth
account    include      password-auth
session    include      password-auth
auth       required     pam_unix.so nullok
account    required     pam_unix.so

cat auth-system.conf.ext PAM authentication. Preferred nowadays by most systems. PAM is typically used with either userdb passwd or userdb static. REMEMBER: You'll need /etc/pam.d/dovecot file created for PAM authentication to actually work. <doc/wiki/PasswordDatabase.PAM.txt> passdb { driver = pam # [session=yes] [setcred=yes] [failure_show_msg=yes] [max_requests=<n>] # [cache_key=<key>] [<service name>] #args = dovecot }

  • Have you previosuly connected successfully using a different email client? Have you tried authenticating your imap user locally... using doveadm ... Doveadm-auth reference page – RubberStamp Oct 30 '17 at 17:44
  • [root@server ]# doveadm auth test -x service=imap -x rip=192.168.10.8 testuser Password: passdb: testuser auth succeeded extra fields: user=testuser This works fine but cant authenticate when using outlook or thunderbird. – Bower Oct 31 '17 at 9:11
1

I have solved the issue, after following this guide http://xmodulo.com/enable-user-authentication-postfix-smtp-server-sasl.html

It still didn't work, but turns out it was because my password had a '£' in which was causing the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.