5

GNU IceCat is the primary target for the LibreJS extension, making it a stable platform for running that extension.

So, I'd like to install Ice Cat on my Debian-based systems (running Debian, Ubuntu and PureOS). How can I do this? I'm happy to do crazy things up to and including using the Guix package manager, as long as I can launch the browser in a regular GNOME/Wayland session.

1
5

Download the latest version from ftp.gnu.org unpack it then create a symlink to run Icecat from the terminal:

wget http://ftp.gnu.org/gnu/gnuzilla/52.6.0/icecat-52.6.0.en-US.gnulinux-x86_64.tar.bz2
tar xvf icecat-52.6.0.en-US.gnulinux-x86_64.tar.bz2
sudo ln -s $PWD/icecat/icecat-bin /usr/bin/icecat
icecat

Using the guix pacakge manager:

$ guix package -i icecat

The binary should be set under /home/$USER/.guix-profile/bin/icecat. (see 3.2 Invoking guix package).Assuming guix is correctly configured and the $USER/.guix-profile/bin is in your $PATH , you can start the browser from the terminal through:

$ icecat
2

Sparky and Trisquel already contains the .deb package of icecat.

apt-key adv --fetch-keys https://sparkylinux.org/repo/sparkylinux.gpg.key

echo 'deb http://sparkylinux.org/repo testing main' > /etc/apt/sources.list.d/sparky.list

or

apt-key adv --fetch-keys http://packages.trisquel.info/trisquel/trisquel-archive-signkey.gpg

echo 'deb http://packages.trisquel.info/trisquel/ flidas-updates main' > /etc/apt/sources.list.d/trisquel.list

Notes

  • If you wanna use with older distribution, then look at trisquel distro names which is the closest for yours.
  • WARNING: This may also update existing packages, install new packages or suggest removing important packages (for example with apt dist-upgrade). Note, though, that it will not automatically remove packages.
2

The GNU Guix package manager is a great way to get IceCat on any GNU/Linux distribution. Download and install Guix, then run: guix install icecat.

Guix also has a whole lot of other relatively new versions of software, so can be a great way to install packages such as NodeJS on top of stable versions of Debian.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.