2

Since I installed virtualbox 5.0.40 on a mint 18.2 (mate) box I have not been able to connect my usb devices to my virtual machines I have added guest additions and in my usb configurations I select USB3.0 (I tried other settings as well but nothing) but from my virtual machines menu>Devices>USB I get get an empty list.

Would greatly appreciate any suggestions.

0
3

You need to install the VirtualBox Extension Pack to use USB functionalities. Check if you have it installed: https://www.virtualbox.org/manual/ch01.html#intro-installing

The VirtualBox 5.0.40 version is no longer supported (ended 2017/05), so it's recommended that you upgrade your VirtualBox too. However, if you do not wish to update your VirtualBox, you can download the respective Extension Pack here: http://download.virtualbox.org/virtualbox/5.0.40/Oracle_VM_VirtualBox_Extension_Pack-5.0.40-115130.vbox-extpack

EDIT [SOLUTION]: As discussed in the comments the problem was solved adding the Linux user that starts VirtualBox to the vboxusers group.

2
  • I have already installed the extension pack. In the settings I select USB3.0 but from my virtual machine when I go to devices>USB it does not show any of my attached devices – natral Oct 31 '17 at 20:56
  • Check if your Linux user is included in the vboxusers group (to check it you can use the command groups myuser). If not, run sudo usermod -a -G vboxusers myuser, reopen VirtualBox and check the USB devices again. – Eduardo Baitello Oct 31 '17 at 21:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.