0

So following some suggestions, I tried:

$ aplay -l | grep card
card 0: PCH [HDA Intel PCH], device 0: CX20724 Analog [CX20724 Analog]
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
card 1: ml1 [sonible ml:1], device 0: USB Audio [USB Audio]

The last device is the one I want. I doesn't show up in Pulse Audio:

enter image description here

I randomly try names:

$ pactl load-module module-alsa-sink device=ml:1
Failure: Module initialization failed

$ pactl load-module module-alsa-sink device=ml1
Failure: Module initialization failed

$ pactl load-module module-alsa-sink device=hw:1
Failure: Module initialization failed

None of this works. This is a class-compliant stereo USB sound cards, works fine in Jack.


I'm trying again with PA info:

$ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 32
Server Protocol Version: 32
Is Local: yes
Client Index: 12
Tile Size: 65472
User Name: me
Host Name: debian
Server Name: pulseaudio
Server Version: 10.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: 0ea3:acfe

$ pactl list short sources
0   alsa_output.usb-sonible_ml_1_V000014_sonible_ml_1-00.analog-stereo.monitor  module-alsa-card.c  s16le 2ch 44100Hz   SUSPENDED
1   alsa_output.pci-0000_00_1f.3.analog-stereo.monitor  module-alsa-card.c  s16le 2ch 48000Hz   IDLE
2   alsa_input.pci-0000_00_1f.3.analog-stereo   module-alsa-card.c  s16le 2ch 48000Hz   SUSPENDED

$ pactl load-module module-alsa-sink device=alsa_output.usb-sonible_ml_1_V000014_sonible_ml_1-00.analog-stereo.monitor
Failure: Module initialization failed

$ sudo pactl load-module module-alsa-sink device=alsa_output.usb-sonible_ml_1_V000014_sonible_ml_1-00.analog-stereo.monitor
Connection failure: Connection refused
pa_context_connect() failed: Connection refused
  • run pavucontrol and click on configuration. – Ipor Sircer Oct 30 '17 at 15:44
  • It's funny that you have an associated monitor source for the USB device, but the sink itself doesn't show up. So possibly something goes wrong during initialization. Edit question with output of pactl list short sinks. Anything relevant in dmesg or syslog wrt. Pulseaudio after you plug in the USB device? Anything that could be using the USB device, and prevent Pulseaudio from using it? – dirkt Oct 30 '17 at 15:54
0

I could not find a way to make that device appear. But there is a fallback solution: Sending PA through Jack:

pactl load-module module-jack-sink channels=2
pactl load-module module-jack-source channels=2

Then run Jack, e.g. QJackCtl, and you then set, for example in VLC, the pulse audio output device to 'Jack sink'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.