I have been trying to install a gedit plugin called RunC to compile C programs using the text editor.

Although the instructions tell me to use ubuntu 9 or 10 for this, I'm currently running Fedora 16. I thought that I would not have much problems, but after running the shell script using the sh command to install the plugin, gedit showed no signs of the plugin being installed. I've made sure that gedit is updated to the current release.

Is there something I'm missing from this installation? Additionally, does the file structure of various distributions differ greatly from each other? Will scripts that work for one distro be incompatible with another?

Thanks for indulging me with my silly questions.

Attached below is the RunC plugin for gedit: http://plg1.uwaterloo.ca/~gvcormac/RunC/

  • The quick answer for the quick question is that "yes" distro's can vary by quite a bit, and if scripts do not take certain things into account, they will not be cross-distro.
    – Tim
    Jun 6 '12 at 13:54
  • The manual shows to press "Control+R" to compile a script, did you try that after "installing"?
    – Tim
    Jun 6 '12 at 13:56
  • yes i did. Turns out that the program no longer worked with newer linux distros. I tried it with Ubuntu 11.10 with the same results.
    – WhiteBit
    Jun 7 '12 at 0:25
  • Please answer your own question with what you found out, and accept the answer. Thanks!
    – vonbrand
    Jan 29 '13 at 12:01

I didn't manage to install it because RunC wasn't compatible with other distros. I confirmed this by installing Ubuntu 10, and it worked perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.