1

Having some problems with booting in Centos 7 since the last update. The Centos 7 partition does not boot due to a soft kernel panic after the following error is thrown *ERROR* atombios stuck in loop for more than 5secs aborting. I cannot find back the trace of the error in /var/log/messages. Also, there is no hardware error as far as I know since I can boot perfectly well in an older version of Centos.

Below are the specifics about the particular situation, but first more in general: How should I proceed in troubleshooting kernel panic during boot (when there are no logs stored)?

Here are screenshots of the kernel panic message: enter image description here enter image description here

Note: A lot of similar problems are mentioned in other posts at first boot after the installation. This is not the case for me, I have been working perfectly fine on Centos for a couple of months now. I would like to avoid reinstalling Centos for exactly this reason.

As I told before, I have several versions of Centos 7 to choose from during boot time, see particular kernel versions below. The upper one (newest) is the one failing to boot. Unable to find a solution, I'm using the second from the top already for some time now.

enter image description here

possible solutions taken into account already:

The last one didn't help since I get the following error at boot time:

enter image description here

  • Regarding the last error, fix your boot device order in your BIOS, save settings and reboot; that is unless you don't want to boot off the network. – schaiba Oct 30 '17 at 7:33
  • It seems you're having an issue with the amdgpu graphic driver. Maybe you can update the system while booting on the second kernel as you do? Isn't there updates for the graphic driver ? – Pierre-Alain TORET Oct 31 '17 at 13:49
  • 1
    @schaiba: tried fixing the boot order, but a similar error occurred irrelevantly of the first boot device (options were diskette drive, internal HDD, USB storage device, CD/DVD/CD-RW Drive, Onboard NIC, I tried internal HDD and onboard NIC) @ daftaupe: did run again sudo yum update, there was a new kernel version that shows up in the boot options, but there is again kernel panic at boot time concerning amdgpu. Any idea where I can report this issue to be solved in a future release? – user2416984 Nov 3 '17 at 8:15
2

I found an ongoing discussion on this issue on Red Hat discussions and the CentOS bug tracker. It has to do with the graphics driver of my pc (AMD driver, working on a DELL computer). Bug appears for the 3.10.0-693 kernel version.

A workaround for the moment is to add nomodeset to the grub boot command line, as suggested in the links. A good explanation on the meaning of this option and on how to change the grub boot command line (with some small adjustments on CentOS) can be found on this Ubuntu forum discussion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.