I am running Arch Linux 64 bit - 4.13.8-1

I tried Ledger's fix by adding udev rules and changing owner:

"OWNER="USER", SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="1b7c", MODE="0660", TAG+="uaccess", TAG+="udev-acl"
"OWNER="USER", SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="2b7c", MODE="0660", TAG+="uaccess", TAG+="udev-acl"
"OWNER="USER", SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="3b7c", MODE="0660", TAG+="uaccess", TAG+="udev-acl"
"OWNER="USER", SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="4b7c", MODE="0660", TAG+="uaccess", TAG+="udev-acl"
"OWNER="USER", SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="1807", MODE="0660", TAG+="uaccess", TAG+="udev-acl"
"OWNER="USER", SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="1808", MODE="0660", TAG+="uaccess", TAG+="udev-acl"
"OWNER="USER", SUBSYSTEMS=="usb", ATTRS{idVendor}=="2c97", ATTRS{idProduct}=="0000", MODE="0660", TAG+="uaccess", TAG+="udev-acl"
"OWNER="USER", KERNEL=="hidraw*", SUBSYSTEM=="hidraw", MODE="0660", GROUP="plugdev", ATTRS{idVendor}=="2c97"
"OWNER="USER", KERNEL=="hidraw*", SUBSYSTEM=="hidraw", MODE="0660", GROUP="plugdev", ATTRS{idVendor}=="2581"ess", TAG+="udev-acl"

HW File:

-rw-r--r-- 1 USER users 1386 Oct 28 13:43 20-hw1.rules

The device does show up with dmesg -w:

hid-generic 0003:2C97:0001.003A: hiddev1,hidraw9: USB HID v1.11 Device [Ledger Nano S] on usb-0000:00:14.0-6/input0

Yet I cannot get the Ledger Manager or Wallet to recognize my Ledger. What am I missing here?


Unfortunately the term "app" is used for two different things. There are:

  • the chrome apps which run on your browser (duh...)
  • the ledger apps which run on the USB.

Not much we can do... Anyway.

  1. Do not install any of the Chrome apps. If you already installed some of them uninstall them.

  2. Create the following file. Do take note that you need to replace the value of the GROUP attribute with a group that your user belongs to. On Archlinux, if you follow the Install guide, a group with the same name as your user should exist. That's what you should use. On other distros, it might be something like users.

    $ cat /etc/udev/rules.d/20-hw1.rules
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="1b7c", MODE="0660", GROUP="replace_with_your_user_name"
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="2b7c", MODE="0660", GROUP="replace_with_your_user_name"
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="3b7c", MODE="0660", GROUP="replace_with_your_user_name"
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="4b7c", MODE="0660", GROUP="replace_with_your_user_name"
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="1807", MODE="0660", GROUP="replace_with_your_user_name"
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="1808", MODE="0660", GROUP="replace_with_your_user_name"
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="2c97", ATTRS{idProduct}=="0000", MODE="0660", GROUP="replace_with_your_user_name"
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="2c97", ATTRS{idProduct}=="0001", MODE="0660", GROUP="replace_with_your_user_name"
  3. Install the Ledger Wallet Manager. This is a chrome app and you use it to update the firmware on the USB.

  4. Start the Manager app. You will see a list of ledger apps which you can install on your wallet. Delete the existing ones (BTC and ETH) and reinstall them. You can now use your wallet.

  5. Install the Ledger Wallet BTC App. This is the chrome app you use to make transactions.

  6. Install additional Ledger Wallet apps (e.g. the ETH one).



I struggled with this for months and finally found a fix that works every time. I thought some kernel updates had finally fixed the problem for good, but I noticed that after one reboot, the machine couldn't see my nano again.

THE FIX: It's so stupid, you'll smack yourself (if it works for you, that is). I'm assuming you've tried everything else already, and that you've run the script from Ledger that adds the udev rules, etc, etc.

Step 1: Plug in your nano to the PC's USB port and unlock it by entering your pin. Leave it unlocked and go to step 2 right away.

Step 2: Reboot the pc (the computers I've tested this on kept the nano powered through a reboot, so I think this is necessary)

Step 3:Try the Chrome apps/MEW now.

When I noticed that the lsusb command gave different results when the device was locked compared to when it was unlocked, I thought of how Linux sometimes needs to boot up with a USB peripheral plugged in to get it to recognize correctly. This didn't occur to me, because the nano WAS plugged in... EVERY TIME I WAS STRUGGLING WITH THIS - IT WAS PLUGGED IN...... just not unlocked during reboot every time. I assume this is also why my testing kept giving me different results - sometimes I was rebooting with the Nano unlocked, sometimes when is was locked... but always plugged in - this is what threw me off the scent of the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.