1

TL;DR: custom partitions and trash is not showing on Thunar via AwesomeVM.

XFCE: XFCE Awesome: Awesome

My fstab is:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>                           <mount point>  <type>  <options>  <dump>  <pass>
UUID=619542b0-8ce0-4dd1-9b0b-2d6224aa4f98 swap           swap    defaults,noatime 0       0
UUID=c49099f0-a6d7-4732-b41d-c34a7246019c /              ext4    defaults,noatime 0       1
# /dev/sdb1 (games)
UUID=01CF50ED2AA59680                     /mnt/games     ntfs defaults,rw,uid=1000,umask=003,x-gvfs-show 0       0
# /dev/sdb2 (data)
UUID=3F2BFCA2397DA8FB                     /mnt/data      ntfs defaults,rw,uid=1000,umask=003,x-gvfs-show 0       0
# /dev/sda4 (docs)
UUID=56D6C95328FD7038                     /mnt/docs      ntfs defaults,rw,uid=1000,umask=003,x-gvfs-show 0   0

# /dev/sdb3 (extra)
UUID=57b79234-ae2a-4206-9e53-95e6a6009fd5 /mnt/extra     ext4    defaults,rw,x-gvfs-show 0       1

BTW, I know that this is in some way related to gvfs, which I already have running when I logged through AwesomeVM, but I need some more? I don't understand why don't works.

5
  • Do you have the gvfs package installed? Thunar in my Awesome WM system shows both USB mounts and the bin.
    – l0b0
    Oct 30, 2017 at 1:33
  • Yes, I have, as I said I have gvfs running on AwesomeWM. The picture from the XFCE is the same machine, I just installed Awesome and I'm running alternatively one or other. Oct 30, 2017 at 3:46
  • BTW, the processes gvfs related running on my awesome are: i.imgur.com/7Da1eo4.png. Oct 31, 2017 at 6:32
  • On XFCE, however, I have more processes related to gvfs: i.imgur.com/jeVTjuw.png I'm just thinking how they are triggered on xfce... Oct 31, 2017 at 6:44
  • Can you show your process list in both situations (with minimal other stuff running)? That might clarify things.
    – l0b0
    Oct 31, 2017 at 18:28

1 Answer 1

2

Finally I found the reason. This bug is related to lightDM starting awesome without dbus-launch. I fixed the whole problem described here by editing by hand the file /usr/share/xsessions/awesome.desktop as:

[Desktop Entry]
Name=awesome
Comment=Highly configurable framework window manager
TryExec=awesome
Exec=dbus-launch --exit-with-session --sh-syntax awesome
Type=Application

This is not a very pleasant solution and neither a good one, since I editing that file this thing will be mess-up when I got a new update of awesome and /usr/share/xsession/awesome.desktop be overwritten.

Looking forward for better solutions, but for now, only for now, this is working pretty fine. Trash appears now on thunar, xfdesktop and x-gvfs-show-partitions it's working as expected.

1
  • 1
    I will try that with caja! Althouh the x-gvfs-show mount option, only root sees all drives in the - what is it called - places pane!?!
    – WGRM
    Mar 8, 2020 at 14:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .