0

I am trying to get xdmcp working on a Redhat 6 server.

I am mostly following the steps at: http://www.yolinux.com/TUTORIALS/GDM_XDMCP.html#RHEL

In one of the steps it suggests:

Edit file:
Red Hat: /etc/X11/xdm/Xaccess

On my system, I do not see this file or the xdm folder. I only have /etc/X11:

$ ls -l /etc/X11
total 32
drwxr-xr-x. 2 root root 4096 Jun 29  2011 applnk
drwxr-xr-x. 2 root root 4096 Oct  2  2013 fontpath.d
-rwxr-xr-x  1 root root 1328 Aug 26  2014 prefdm
drwxr-xr-x  4 root root 4096 Oct 29 17:43 xinit
-rw-r--r--  1 root root  547 Jun  6  2013 Xmodmap
-rw-r--r--. 1 root root   68 Oct  2  2013 xorg.conf
drwxr-xr-x  2 root root 4096 Nov  3  2016 xorg.conf.d
-rw-r--r--  1 root root  493 Jun  6  2013 Xresources

So far, I am getting a blank screen if I try to open an xdmcp session via mobaXTerm.

I have already followed most of the steps in the tutorial I noted above including disabling my firewall.

I also have gdm running:

$ ps -eaf | grep gdm
root      1818     1  0 20:07 ?        00:00:00 /usr/sbin/gdm-binary -nodaemon
root      1848  1818  0 20:07 ?        00:00:00 /usr/libexec/gdm-simple-slave --display-id /org/gnome/DisplayManager/Display1
root      1851  1848  0 20:07 tty1     00:00:00 /usr/bin/Xorg :0 -br -verbose -audit 4 -auth /var/run/gdm/auth-for-gdm-h5txFF/database vt1
gdm       1937     1  0 20:07 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session
gdm       1938     1  0 20:07 ?        00:00:00 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
gdm       1939  1848  0 20:07 ?        00:00:00 /usr/bin/gnome-session --autostart=/usr/share/gdm/autostart/LoginWindow/
gdm       1946     1  0 20:07 ?        00:00:00 /usr/libexec/gconfd-2
gdm       1964  1939  0 20:07 ?        00:00:00 /usr/libexec/at-spi-registryd
gdm       1965     1  0 20:07 ?        00:00:05 /usr/libexec/gnome-settings-daemon --gconf-prefix=/apps/gdm/simple-greeter/settings-manager-plugins
gdm       1967     1  0 20:07 ?        00:00:00 /usr/libexec/bonobo-activation-server --ac-activate --ior-output-fd=12
gdm       1974     1  0 20:07 ?        00:00:00 /usr/libexec/gvfsd
gdm       1975  1939  0 20:07 ?        00:00:00 metacity
gdm       1976  1939  0 20:07 ?        00:00:00 /usr/libexec/polkit-gnome-authentication-agent-1
gdm       1978  1939  0 20:07 ?        00:00:00 /usr/libexec/gdm-simple-greeter
gdm       1991     1  0 20:07 ?        00:00:00 /usr/bin/pulseaudio --start --log-target=syslog
root      1998  1848  0 20:07 ?        00:00:00 pam: gdm-password

At this point though, I do wish to be sure I have done the necessary xdm config. But how is it done with Redhat 6?

0

The only file you should really need to change on RHEL 6 would be the /etc/gdm/custom.conf. Did you set this to Enable=true and restarted GDM?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.