0

My hair is falling out already on the account of samba share issues.

  • I have an ext4 samba share on a raspberry pi, with a mask 0777 specified.
  • Only myuser on raspberry can authenticate via samba.
  • chmod -R and chown were run on the folders to fix (self-created) authorization issues.
  • myuser was added to group debian-transmission in order to access torrented files properly from my laptop.
  • From my notebook I access files with myuser with the appropriate password via samba.

Now, newly downloaded files and folders have the owner colord and group avahi-autoipd, and I cannot make sense of it. I also have only read access from the notebook. How can I fix this?

Edit: the owner on the server is debian-transmission, the owner checked with ls -l is colors, with group avahi-autopid...

Edit2: per @X Tian's comment, the uid and gid on the notebook indeed equals to user and group debian-transmission on the samba server.

  • From where do you down load & look at the actual user ID/group I'd of the downloaded files not name since it really works with id's and names are worked out by ls using /etc/passwd – X Tian Oct 29 '17 at 10:21
  • 1
    Sorry, I mean use -n option on ls to look at actual numeric id's not their name translation because passed file may have different names for those id's. – X Tian Oct 29 '17 at 10:26
0

I think it could be two possible options to solve your problem.

1) Try to add

force user = myuser force group = debian-transmission

to [global] section in /etc/samba/smb.conf

2) Second option. I'm not sure if it works, but you should try if first method fails. Add sticky bit to shared folder.

chmod 2770 SHARED_FOLDER find SHARED_FOLDER -type d -exec chmod g+s {} \;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.