0

Fedora 26 with KDE Plasma.

I want to set a locale, but bash (and other programs) seems to ignore my system settings (localectl). Things I tried:

  1. Setting via "localectl"
  2. Editing /etc/locale.conf
  3. Seting via env variable (export LANG="C.utf8") both in /etc/profile and ~/.bash_profile

output of "locale" on newly opened bash:

[ ~]$ locale
LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=

Output of localectl

[ ~]$ localectl
   System Locale: LANG=C.utf8
       VC Keymap: us
      X11 Layout: us
       X11 Model: pc105+inet

Output of locale -a

[ ~]$ locale -a
C
C.utf8
POSIX
...
(list goes on)

Exporting env variable works, but only for that bash session.

0

Fixed after editing these files/lines:

~/.config/plasma-localerc:LANG=en_US.US-ASCII
~/.config/plasma-locale-settings.sh:export LANG=en_US.US-ASCII
  • Its written there as # Generated script, do not edit # Exports language-format specific env vars from startkde. # This script has been generated from kcmshell5 formats. # It will automatically be overwritten from there.....what about this. – Neo_Returns May 19 '18 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.