I installed fedora 26 just before on my thinkpad T440p but I can't manage to get my touchpad working correctly, and don't really see what to do more...

xinput list

just returns

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ xwayland-pointer:13                   id=6    [slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:13          id=7    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard           id=5    [slave  keyboard (3)]
    ↳ xwayland-keyboard:13                  id=8    [slave  keyboard (3)]

and /etc/X11/xorg.conf.d/30-touchpad.conf is

Section  "InputClass"
    Identifier  "touchpad overrides"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "TappingButtonMap" "lmr"

I have already read quite a lot of threads but none of them actually worked (i rebooted each time)

A strange thing that might help is that

libinput list-devices


Device:           Synaptics TM2939-001
Kernel:           /dev/input/event17
Group:            9
Seat:             seat0, default
Size:             97x69mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

but I have the Tap to click and Natural Scrolling actually working, even if they are written disabled there...

So is there any other way to edit the libinput properties?

Thanks a lot!

closed as off-topic by jasonwryan, Stephen Rauch, Jeff Schaller, DarkHeart, Archemar Oct 28 '17 at 8:42

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – jasonwryan, Stephen Rauch, Jeff Schaller, DarkHeart, Archemar
If this question can be reworded to fit the rules in the help center, please edit the question.


Ok... It was quite dumb actually, I just changed "Click method" from "default" to "finger" in tweak-tools and it made it

Not the answer you're looking for? Browse other questions tagged or ask your own question.