1

I'm trying to use qemu, but whenever I try to start it, I get this error message:

[x86-64-debug] me:~/fuchsia$ frun -g
+ echo CMDLINE: TERM=xterm-256color kernel.entropy-mixin=540cde8490a5d80fdb709ff7dcbf6094d92a40dc7d9cfed901758756a666e9dc kernel.halt-on-panic=true
CMDLINE: TERM=xterm-256color kernel.entropy-mixin=540cde8490a5d80fdb709ff7dcbf6094d92a40dc7d9cfed901758756a666e9dc kernel.halt-on-panic=true
+ exec /home/colton/androidstuff/fuchsia/buildtools/linux-x64/qemu/bin/qemu-system-x86_64 -m 2048 -serial stdio -vga std -net none -smp 4,threads=2 -machine q35 -kernel /home/colton/androidstuff/fuchsia/out/build-zircon/build-zircon-pc-x86-64/zircon.bin -cpu Haswell,+smap,-check -initrd /home/colton/androidstuff/fuchsia/out/debug-x86-64/user.bootfs -append 'TERM=xterm-256color kernel.entropy-mixin=540cde8490a5d80fdb709ff7dcbf6094d92a40dc7d9cfed901758756a666e9dc kernel.halt-on-panic=true '
Could not initialize SDL(x11 not available) - exiting`

(I'm trying to build Google's Fuchsia repository)

I've already looked around, but nothing has worked (most people get a display unavailable error message or they run into this problem in R).

I'm running Ubuntu Budgie

Any ideas as to how to fix this?

0

I also encountered problems with the run zircon kernel of fucsia.

if you do the command

./scripts/run-zircon-x86-64

I get a mistake

I resolved to take it off

-check,-fsgsbase

from the flag

-cpu Haswell,+smap,-check,-fsgsbase

it must be a problem with my CPU

I did not want to start fuchsia but only the zircon kernel, with this small change I can. I do not know if it's your case

  • I don't see these flags in that script. anywhere else you might see it? – Colton Donnelly Nov 8 '17 at 7:09
  • This wasn't the problem for me. Turns out, qemu won't play nice with Linux kernel anymore, as the kernel is moving towards Wayland – Colton Donnelly Nov 8 '17 at 19:24
0

As it turns out, the Linux kernel is starting to move towards Wayland, rather than X11, starting with 17.10. Because of this, qemu won't work well anymore.

  • 1
    You mean, Linux distributions are moving towards Wayland. The kernel itself is totally GUI agnostic. And nothing prevents you from running an X server even on distros which default to Wayland. Also, SDL (look at the error message) doesn't even need X (if you configure it properly). – dirkt Nov 8 '17 at 21:23
  • @dirkt right. Still learning a bit. Thanks for letting me know. – Colton Donnelly Nov 9 '17 at 15:39
  • @dirkt any resources for configuring sdl to not need x? I came up with nothing on Google – Colton Donnelly Nov 9 '17 at 15:59
  • See e.g. wiki.archlinux.org/index.php/Wayland#SDL2 – dirkt Nov 9 '17 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.