9

At almost each shutdown of my Linux Mint 18.2 Cinnamon 64-bit, I must wait ages at:

a stop job is running for make remote cups printers available locally

Some information I find most useful:

  1. I have one installed local USB printer unattached unless I need it.

  2. That said, I don't have an idea what the system is waiting for.

  3. The printer is HP, so HPLIP has been installed.

  4. I repeat, that at shutdown, the printer is never attached to the USB.

  5. But typically once a week I need to print on it.

  6. May I disable the cups-browsed service to solve this?

I mean:

sudo systemctl disable cups-browsed.service

And the printer would still work?

8

It turns out, that the printer functionality is not damaged by disabling the cups-browsed service:

sudo systemctl stop cups-browsed.service
sudo systemctl disable cups-browsed.service

So, no longer endless waiting for the computer to reboot :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.