9

I have noticed that since some time ago, the following warning message appears when updating grub:

Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
cat /etc/default/grub

lists the following options:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomdmonddf nomdmonisw fsck.mode=force"
GRUB_CMDLINE_LINUX=""

Supposing the following:

  • I don't use grub menu.

  • I want the boot process not to be slowed down by some grub timeout.

What are the valid options for me?

Removing the line:

GRUB_TIMEOUT=10

or something else?

OS: Linux Mint 18.2 Cinnamon 64-bit.

11

I tried different combinations and the result is, that for the file:

/etc/default/grub

in my case, when I don't want the grub menu to appear at all, removing the following line, works:

GRUB_HIDDEN_TIMEOUT=0

while setting:

GRUB_TIMEOUT=0

Afterwards, don't forget to run:

sudo update-grub

The warning no longer appears.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.