I have two Ubuntu systems installed, one 14.04 and one 16.04. From the Grub menu I can see that:

Memory test (memtest86+)
Ubuntu 14.04.4 LTS (on /dev/sda1)
Ubuntu 16.04.2 LTS (on /dev/mapper/ubuntu--vg--root)

Every time, the PC will start by the default Ubuntu option, and load the Ubuntu 14.04. I want to change this default start up to Ubuntu 16.04. However, not successful.

Things I tried:

  1. change /etc/default/grub

    GRUB_DEFAULT="saved" GRUB_SAVEDEFAULT="true" GRUB_HIDDEN_TIMEOUT_QUIET="true" GRUB_TIMEOUT="10" GRUB_DISTRIBUTOR="lsb_release -i -s 2> /dev/null || echo Debian" GRUB_CMDLINE_LINUX_DEFAULT="root=/dev/mapper/ubuntu--vg--root" GRUB_PRELOAD_MODULES="lvm"

Neither GRUB_DEFAULT="saved" or GRUB_DEFAULT="3" is working.

  1. Try to change 40_custom of grub.d not working

  2. In the grub.cfg file, there is no Ubuntu 16.04 (which is really strange as I can see this option in the Grub and I can manually scroll down and choose to start with Ubuntu 16.04).

  3. In the Grub Customizer there is no Ubuntu 16.04, but has Ubuntu 14.04

Please advice what should I do. Thanks.

1 Answer 1


I know only for Bios-Installation. First you need to know which grub is leading (Trust or xenial)

sudo hexdump -v -s 0x80 -n  2 -e '2/1 "%x" "\n"' /dev/sda

Bytecode 48b4 means GRUB 2 (Version 1.96) 7c3c means GRUB 2 (Version 1.97 oder 1.98) 020 means GRUB 2 (Version 1.99) In /etc/default/grub/


Then run sudo update-grub

Then boot xenial and your choice will be remembered. info -f grub -n 'Simple configuration'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.