1

I've been Googling for 2 days and cannot find a fix that works for me.

I'm running into a wall trying to pair a Bluetooth mouse. I think my issue is related to a mismatch between the UUID handles registered to the controller vs the UUID handle in my device (Logitech MX Anywhere 2 - not 2s). Is the right fix to register the UUID profile that's attached to my device with my controller? If so, I'm getting stuck at the registration. Please see info below.

username@systemname:~$ bluetoothctl
[NEW] Controller <controller MAC> galliumos [default]
[NEW] Device <device MAC> MX Anywhere 2

[bluetooth]# show <controller MAC>
Controller <controller MAC>
    Name: galliumos
    Alias: galliumos
    Class: 0x1c010c
    Powered: yes
    Discoverable: no
    Pairable: yes
    UUID: Headset AG                (00001112-0000-1000-8000-00805f9b34fb)
    UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
    UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
    UUID: OBEX File Transfer        (00001106-0000-1000-8000-00805f9b34fb)
    UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
    UUID: OBEX Object Push          (00001105-0000-1000-8000-00805f9b34fb)
    UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
    UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
    UUID: IrMC Sync                 (00001104-0000-1000-8000-00805f9b34fb)
    UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
    UUID: Audio Source              (0000110a-0000-1000-8000-00805f9b34fb)
    UUID: Vendor specific           (00005005-0000-1000-8000-0002ee000001)
    UUID: Message Notification Se.. (00001133-0000-1000-8000-00805f9b34fb)
    UUID: Phonebook Access Server   (0000112f-0000-1000-8000-00805f9b34fb)
    UUID: Message Access Server     (00001132-0000-1000-8000-00805f9b34fb)
    Modalias: usb:v1D6Bp0246d0525
    Discovering: no

[bluetooth]# info <device MAC>
Device <device MAC>
    Name: MX Anywhere 2
    Alias: MX Anywhere 2
    Appearance: 0x03c2
    Icon: input-mouse
    Paired: no
    Trusted: yes
    Blocked: no
    Connected: no
    LegacyPairing: no
    UUID: Human Interface Device    (00001812-0000-1000-8000-00805f9b34fb)

[bluetooth]# register-profile 00001812-0000-1000-8000-00805f9b34fb
Unable to find GattManager proxy
  • 1
    For what it's worth, I finally solved this problem by giving up and getting a different bluetooth mouse (different model from Logitech). It works fine for whatever reason. I never solved my technical question of why the first mouse won't work, but the broader issue is resolved. – John D Mar 5 '18 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.