4
sudo modprobe vboxdrv
modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.10.0-35-generic

Reinstalled dkms but I still get

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall virtualbox-dkms package and load the kernel module by executing

'modprobe vboxdrv'

Ran find /lib/modules/$(uname -r) -name vboxdrv.ko

Output:

beastly@Beastly:~$ find /lib/modules/$(uname -r) -name vboxdrv.ko
beastly@Beastly:~$ 

Ran

beastly@Beastly:~$ sudo apt-cache policy virtualbox

Output:

virtualbox:
  Installed: 5.1.30-dfsg-1
  Candidate: 5.1.30-dfsg-1
  Version table:
 *** 5.1.30-dfsg-1 500
        500 http://us.archive.ubuntu.com/ubuntu artful/multiverse amd64 Packages
        100 /var/lib/dpkg/status

Ran

beastly@Beastly:~$ dkms status

Output:

virtualbox, 5.1.30, 4.13.0-16-generic, x86_64: installed

Ran

beastly@Beastly:~$ (uname -r)

Output:

4.10.0-35-generic
  • 1
    Could you try find /lib/modules/$(uname -r) -name "vboxdrv.ko" and post the output? – rudimeier Oct 26 '17 at 17:04
  • 1
    dkms status please too. – user192526 Oct 27 '17 at 13:08
  • 1
    What is the output of $(uname -r)? – Minix Oct 27 '17 at 16:35
  • Kove: It appears that you have created two accounts. Please go to the Contact page and select “I need to merge user profiles.” – G-Man Oct 27 '17 at 21:37
  • 1
    I'm a little bit confused. Why don't you boot the newest Kernel 4.13.0-16-generic there virtualboxmodul is compiled and in the Kernel. Let me guess this is an ugrade installation. Plese dont tell from xenial. – user192526 Oct 28 '17 at 9:18
2

@ Bahamut. Thank you.

After upgrade from Zesty to Artful, my machine was booting from and older kernel, hence the incompatibility.

sudo reboot

Hit escape and select advance options.

Selected the newest kernel Installed compatible ext pack

 sudo apt-get install virtualbox-ext-pack

VirtualBox runs pristine.

  • if not on system sudo apt install linux-generic – user192526 Oct 29 '17 at 21:56
0

Solutions mentioned above - had not helped me (within (X)ubuntu 18.04, with the recently updated kernel). What worked in my case:

  1. Setup key with:

wget -q -O - http://download.virtualbox.org/virtualbox/debian/oracle_vbox_2016.asc | sudo apt-key add -

  1. Setup repository with:

sudo sh -c 'echo "deb http://download.virtualbox.org/virtualbox/debian cosmic non-free contrib" >> /etc/apt/sources.list.d/virtualbox.org.list'

  1. Download and install the latest version (with all the extra packages related to the VirtualBox) from https://www.virtualbox.org/wiki/Linux_Downloads

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.