1

I'm connecting to a linux server (GoDaddy dedicated server) via SSH to compress incremental backups either via a tar cvfj or tar cvf to make .tar.bz2 or .tar files, respectively.

I've started to run into "Broken pipe" errors when compressing larger backup folders and found these three posts that address how to fix this issue:

However, what I still can't quite see is whether I need to make an adjustment on my server using the ClientAliveInterval directive or on my computer using the ServerAliveInterval. Are those two used interchangeably and it's just up to what I prefer to do?

I added a config file to my .ssh folder on my computer with the following:

ServerAliveInterval 30
ServerAliveCountMax 1200

I also checked the /etc/ssh/sshd_config file on my server which had the following in it:

#ClientAliveInterval 0
#ClientAliveCountMax 3

Which I changed to this:

ClientAliveInterval 60
ClientAliveCountMax 3

I then ran another compression of a large backup folder and I didn't get the "Broken pipe" error. But I'm just wondering now if I need both adjustments—the one on my computer and the one on the server. Or if I can make do with just one of the two. And if so, which one.

Thanks so much! Jutta

0

Either setting should do it.

You specify this on the server so that it affects all clients that connect via ssh or on the client so that it affects the client only.

If you do not use more than one computer to ssh into your server, setting it on the client would be enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.