0

I got this problem since this morning, htop gives following outputs:

enter image description here

Most information disappears, does anyone know what I did wrong for this?

Thanks!

Edit:

Here are a few things I tried:

  1. remove & reinstall htop, does not help

  2. remove htoprc and restart htop, does not help

  3. press "left" many times, does not help

  4. check my command line history, I did not find anything unusual

  • Does top also show high CPU usage and no processes? – Timothy Martin Oct 24 '17 at 21:48
  • @TimothyMartin Output of top is completely normal. – username123 Oct 24 '17 at 22:31
  • Were there any updates that immediately preceded this change in behavior? – Timothy Martin Oct 24 '17 at 22:32
  • @TimothyMartin I do not remember I did anything unusual. I also check my command history, it seems normal to me. – username123 Oct 24 '17 at 22:38
  • @TimothyMartin I suspect I may type something wrong in htop that caused this weird behavior. – username123 Oct 24 '17 at 22:39
0

Some background : I faced the same issue recently.

same issue

My work is mostly on my university high performance cluster and therefore the libraries that I use for computation messes up my account a lot.

The solution that worked for me was to first check which libraries were loaded with ldd /usr/bin/htop. My out was something like this:

linux-vdso.so.1 =>  (0x00007ffedfd87000)
libncursesw.so.5 => /usr/local/Anaconda/Anaconda3/lib/libncursesw.so.5 (0x00002b84c2bc2000)
libtinfo.so.5 => /usr/local/Anaconda/Anaconda3/lib/libtinfo.so.5 (0x00002b84c2df3000)
libm.so.6 => /lib64/libm.so.6 (0x00002b84c304f000)
libgcc_s.so.1 => /usr/local/Anaconda/Anaconda3/lib/libgcc_s.so.1 (0x00002b84c3352000)
libc.so.6 => /lib64/libc.so.6 (0x00002b84c3564000)
libtinfow.so.5 => /usr/local/Anaconda/Anaconda3/lib/./libtinfow.so.5 (0x00002b84c3931000)
/lib64/ld-linux-x86-64.so.2 (0x0000563efed0e000)

It might not be very obvious but the dependencies were met through the Anaconda3 libraries, which is pretty awkward. I had asked to load anaconda module in my ~/.bashrc. This causes a mismatch in the libraries with the ones in the headers.

Solution was to simply unload the anaconda module with module unload python/Anaconda3

P.S. This is a very specific solution that worked for me. Can you please write your out from ldd?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.