3

In past Fedora releases, the Gnome Tweak Tool can be used to turn on HiDPI for Retina displays. However, I found the option missing in Fedora 27 (at least for the beta version I’m using, but it doesn’t feel like this is an issue of the beta).

enter image description here

While trying workarounds, I found this command to be working: (effective after login again)

$ gsettings set org.gnome.desktop.interface scaling-factor 2

But this command does not have good support for some apps, such as Firefox and even the system file browser. I believe there should be some graphical way to do this, am I right?

6

Apparently it's been removed from Tweaks but not from dconf which is why you're still able to do it via terminal... Typical GNOME stuff.
Anyway, as of gnome 3.26, there's a new dconf key under org.gnome.mutter called experimental-features which is of type as (array of strings - it accepts multiple string values) and one particular value enables HiDpi support on Wayland (including fractional values):

• "scale-monitor-framebuffer" — makes mutter default to layout logical monitors
                                in a logical pixel coordinate space, while scaling
                                monitor framebuffers instead of window content, to
                                manage HiDPI monitors. Does not require a restart.

So per the above, fire up dconf-editor and add 'scale-monitor-framebuffer' to the list of experimental features under org.gnome.mutter:

enter image description here

For those who prefer the terminal, follow the instructions here (sure, replacing the values in that example: 'screen-cast', 'remote-desktop' with 'scale-monitor-framebuffer').
Restart your session and you should then be able to set the scaling factor from the control center
Settings > Devices > Displays > Scale:

enter image description here

  • Is the removal of Scaling setting in Tweak a temporary decision because some bugs found, or is it because a change in the design of Tweak? Thanks! – jackxujh Nov 18 '17 at 17:07
  • 2
    I changed the value to ["scale-monitor-framebuffer"] and restarted the VM. But I don't see the Scale setting. On the other hand, I think a 200% scaling would be great for my display, is it possible to do it this way (since the maximum is 150% in your screenshot)? Thanks! – jackxujh Nov 18 '17 at 17:09
  • @jackxujh - 1. I don't know, I'm not a gnome dev. 2. works fine here, though it's a real setup not a VM. 3. from what I gather, the maximum scaling factor varies, the higher the native resolution the higher the max. – don_crissti Nov 18 '17 at 18:30
  • I guess then it has something to do with the VM tool messing around with resolution settings. I do feel that there should be at least a 125% or higher option for the MacBook Pro's 2880*1800 resolution. – jackxujh Nov 19 '17 at 8:20
  • @jackxujh - on a MBP you should have at least up to 200% scaling available – don_crissti Nov 19 '17 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.