1

I am trying to mine Monero with my VPS, but I encountered an error when trying to enable large pages support. The miner I am trying to use is XMR STAK CPU, but I do not believe this to be the issue, although when I run it, it says "MEMORY ALLOC FAILED: mmap failed".

I am running Centos 7 and I complied the miner myself. I tried doing what it says to do in the README, but the command fails even when executing as root.

$ sudo sysctl -w vm.nr_hugepages=128
sysctl: permission denied on key 'vm.nr_hugepages'

I also added these lines to /etc/security/limits.conf

* soft memlock 262144
* hard memlock 262144

Even running the miner as root doesn't solve my problem.

Additional resources

Here is my strace output: https://pastebin.com/W3QJ8jne

Here is my syslog: https://pastebin.com/drt3Nhcv

SELinux is set to permissive mode as well.

dmesg doesn't output anything...

0

With respect to sudo sysctl -w vm.nr_hugepages=128, I know some settings available in sysctl are not modifiable after boot, I don't know if this is one of them or not.

I recommend adding vm.nr_hugepages = 128 to your /etc/sysctl.conf file and rebooting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.