0

I tried to install nginx in a RHEL 7.2 machine, and i got an error,

Error: Package: 1:nginx-1.10.2-2.el7.x86_64 (epel)
       Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Nut this libcrypto.so.10(OPENSSL_1.0.2)(64bit) is not available on default openssl package so i removed the current openssl package and installed using rpm as below,

[root@db-brm ~]# rpm -Uvh http://mirror.centos.org/centos/7/os/x86_64/Packages/openssl-libs-1.0.2k-8.el7.x86_64.rpm

I thought it would solve the issue but it did not and it increase the conflict in openssl and giving error while installing nginx,

I could see this is the error,

[root@db-brm ~]# yum install nginx
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You 
can use subscription-manager to register.
epel/x86_64/metalink                                                                                                                                       
|  16 kB  00:00:00     
local-repo                                                                                                                                                 
| 4.1 kB  00:00:00     
nginx                                                                                                                                                      
| 2.9 kB  00:00:00     
Resolving Dependencies
--> Running transaction check
---> Package nginx.x86_64 1:1.12.2-1.el7_4.ngx will be installed
--> Processing Dependency: openssl >= 1.0.2 for package: 1:nginx-1.12.2-1.el7_4.ngx.x86_64
--> Running transaction check
---> Package openssl.x86_64 1:1.0.1e-42.el7_1.9 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-42.el7_1.9 for package: 1:openssl-1.0.1e-42.el7_1.9.x86_64
--> Finished Dependency Resolution
Error: Package: 1:openssl-1.0.1e-42.el7_1.9.x86_64 (local-repo)
       Requires: openssl-libs(x86-64) = 1:1.0.1e-42.el7_1.9
       Installed: 1:openssl-libs-1.0.2k-8.el7.x86_64 (installed)
           openssl-libs(x86-64) = 1:1.0.2k-8.el7
       Available: 1:openssl-libs-1.0.1e-42.el7_1.9.x86_64 (local-repo)
           openssl-libs(x86-64) = 1:1.0.1e-42.el7_1.9
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Can anyone help me to solve this issue?

2

Seems like there are some problems with last nginx version. In my case yum install nginx-1.12.1 helped

  • Thanks this worked for me . Even 1.12.2 does not work . – I.Tyger Aug 21 at 14:46
0

run yum --showduplicates list nginx

try to install some other nginx version

for me yum install nginx-1.10.1-1.el7 works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.