0

I Have installed the last version of FreeBSD in my machine, the problem is that i use 2 monitors, i have installed the XFCE with Xorgs and works fine, but my second monitor they are mirrored the first one but in ´xrandr´ they are not detected, just the first, so i cant configure the second monitor. My video card is an Intel, and i have migrated from Fedora with XFCE and works Fine. What i can do about that?

Xorg.conf

Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath   "/usr/local/lib/xorg/modules"
FontPath     "/usr/local/share/fonts/misc/"
FontPath     "/usr/local/share/fonts/TTF/"
FontPath     "/usr/local/share/fonts/OTF/"
FontPath     "/usr/local/share/fonts/Type1/"
FontPath     "/usr/local/share/fonts/100dpi/"
FontPath     "/usr/local/share/fonts/75dpi/"
EndSection

Section "Module"
Load  "glx"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection
Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option      "Protocol" "auto"
Option      "Device" "/dev/sysmouse"
Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
    ### <percent>: "<f>%"
    ### [arg]: arg optional
    #Option     "ShadowFB"              # [<bool>]
    #Option     "DefaultRefresh"        # [<bool>]
    #Option     "ModeSetClearScreen"    # [<bool>]
Identifier  "Card0"
Driver      "vesa"
BusID       "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
    Viewport   0 0
    Depth     1
EndSubSection
SubSection "Display"
    Viewport   0 0
    Depth     4
EndSubSection
SubSection "Display"
    Viewport   0 0
    Depth     8
EndSubSection
SubSection "Display"
    Viewport   0 0
    Depth     15
EndSubSection
SubSection "Display"
    Viewport   0 0
    Depth     16
EndSubSection
SubSection "Display"
    Viewport   0 0
    Depth     24
EndSubSection
EndSection
3
  • Adding the output of xrandr would be useful. And then try xrandr --auto. Finally delete your xorg.conf. Most things are autodetected today - so you often make things worse by configuring manually. See freebsd.org/doc/handbook/x-config.html Oct 24, 2017 at 10:22
  • If only one screen is seen with xrandr then look for "no screen found" in the X log as per unix.stackexchange.com/a/196084/74393 Oct 24, 2017 at 10:28
  • And finally - your manually configured xorg.conf is using the vesa driver. The answer referenced above states that vesa driver does not support dual head. Try autodetection first - and look at the X log when starting to see what is detected Oct 24, 2017 at 10:34

1 Answer 1

0

I solved my problem entering into ports and rebuilding the xorgs drivers only with Intel, Mouse and Keyboard checked. After that, I rebooted and the both monitors are available in xrandr.

1
  • 1
    Changing your xorg.conf line Driver "vesa" to Driver "intel" probably would have the same effect. Oct 26, 2017 at 11:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .